0 Favourites

C2 Crash

  • Problem Description

    ____ ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Layout view: drawing deleted instance

    Condition: !i->instance->IsDeleted()

    File: Editors\CLayoutView.cpp

    Line: 438

    Function: void __cdecl CLayoutView::DoDraw(bool)

    Build: release 230 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

    did not crash on retry the 2nd the this appeared ____

    Attach a Capx

    ____ I rather don't.. sorry! ____

    Description of Capx

    ____ it's a mobile game with currently around 30 layouts, 14mb of music and 2 sound effects, i have not recently deleted any item from the project.____

    Steps to Reproduce Bug

    • was previewing the game on monitor3
    • moved the mouse to monitor 1 (C2 is spread across monitor 1 & 2, i use Monitor 1 for the code /split layout)
    • clicked on "Add Action" under: "Touch 0 speed > 1000 & Scrollspeed*GlobalVar* = 0 - abs(touch.angleat(0)) >0 <0180
    • Error message.

    Observed Result

    ____ Error message, crashed C2 on ignore, 2nd time did not crash on clicking retry ____

    Expected Result

    ____ What do you expect to happen? ____ this is a strange question.. i expected the menu popup of adding actions, which did popup after the retry

    Affected Browsers

    • Chrome: (/NO)
    • FireFox: (/NO)
    • Internet Explorer: (/NO)

    Operating System and Service Pack

    ____ Your operating system and service pack ____ W10 up to date July 18.

    Construct 2 Version ID

    ____ Exact version ID of Construct 2 you're using ____ 230 - 64bit.

  • Anonynoise

    There is nothing anyone - including Ashley - can do with this report as it doesn't follow the Bug Report Requirements, so is likely to be closed by Ashley automatically.

    Are you using any non-standard plugins? Does it happen every time the same way?

    If you can describe it, then you should be able to recreate it in a new simple .capx with precise steps.

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Closing, please see the bug report requirements, otherwise we can't help.

  • Anonynoise

    There is nothing anyone - including Ashley - can do with this report as it doesn't follow the Bug Report Requirements, so is likely to be closed by Ashley automatically.

    Are you using any non-standard plugins? Does it happen every time the same way?

    If you can describe it, then you should be able to recreate it in a new simple .capx with precise steps.

    i described it as best as i can, it happened twice, completely out of the blue, randomly. and has not re-occurred since the report.

    i don't use anything non-standard except the separate Node installer which is still pretty much standard (older versions of C2 had it pre-installed, doesn't feel any different now so i consider it standard.)

    but it only happened twice, i think it's just a super unique case (never saw it before in the past years) that solved itself somehow.

    anyways, the error told me to copy-paste the message for the devs.. so i did, too bad it doesn't seem to help in any way tho.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)