0 Favourites

Bug with video error trigger in r227

  • Problem Description

    Following release r227 (or those part of it, since I upgraded from last stable release, r221), the Video plugin has a

    problem with the OnError event. It triggers even without anything having been done with the Video plugin (my code worked

    fine in r221 and now triggers the error routine).

    Ticket reopened after being closed by Ashley without waiting for any feedback! Ashley, please check my reply in the report you closed, thank you.

    Attach a Capx

    Description of Capx

    The code above triggers the Video error as soon as it is run, even before anything is loaded. It has to be this way to reproduce

    the error, as if you immediately load the video (e.g. with the System On Start of Layout), it works fine and doesn't trigger the error.

    Steps to Reproduce Bug

    Create code above

    Run it without pressing the button

    Observed Result

    Error is triggered and browser displays error message "Error detected"

    Expected Result

    Nothing in this case, until you press OK, then video loads and plays fine.

    Affected Browsers

    Chrome: Yes

    FireFox: Yes

    Internet Explorer: Yes

    Operating System and Service Pack

    Windows 7 Professional 64, Sp1 latest patches applied

    Construct 2 Version ID

    r227

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • Should be fixed in the next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)