BlackScreen when i export, testing on program C2 Works fine.

  • Problem Description

    Black Screen when i export.

    Attach a Capx

    CAPX MORE PLUGINS AND BH

    https://1drv.ms/f/s!AgFL0WknQC4yrdlZpzwVt2SglP77Rg

    Description of Capx

    Its a Word Game

    Steps to Reproduce Bug

      When i export the proyect, black screen appears. (export on html5 or NW)

    Observed Result

    I dont see problems when i run the "test" in program but when i export black screen appears

    Expected Result

    ____ What do you expect to happen? ____

    Affected Browsers

      Chrome:YES FireFox: YES Internet Explorer:YES

    Operating System and Service Pack

    I try on Windows 10 and Windows 7

    Construct 2 Version ID

    R241

  • Wooow! i resolve the problem, i add some text to my work with "´" accents. i remove all and work fine on HTML and NW (problem not finish)

  • I have blackscreen when export to UWP (Win 10). I see only html background and nothing else. No errors in console, on preview and other platforms game working fine.

    I tested previous version of my game (created 2-3 days ago) and there's no problem.

  • I have blackscreen when export to UWP (Win 10). I see only html background and nothing else. No errors in console, on preview and other platforms game working fine.

    I tested previous version of my game (created 2-3 days ago) and there's no problem.

    i have problems with windows 10 exports, i see the splashscreen then game crashes with problems in "FIREBASE DATABASE cannot find or get" i use firebase api v3 from REX. I search on internet but i cant find any answer. On NW export or HTML5 works fine. i Cant see the problem.

    the message of DATABASE appears in visual studio 2015 console, i compile the work to win 8.1 phone i try to run on my cellphone and do the same action. Open the game, splashscreen and then the app close.

    im now on my work, at night, i paste the console message. im really interested in windows exports.

  • im thinking, i dont try export with INTEL SDK, I will try today to night and I comment here.

  • This is the message from Visual Studio 2015 console.

    SCRIPT5007: Excepción no controlada en línea 23278, columna 9 en ms-appx://59550spectrelw.ahorcadoejecuciones/c2runtime.js

    0x800a138f - JavaScript runtime error: Unable to get property 'database' of undefined or null reference

    c2runtime.js (23278,9)

    and the line is

    window["Firebase"]["database"]["enableLogging"](this.properties[4] === 1);

    i will try INTEL SDK to night.

  • Okey i was try on XDK INTEL, and i have the same problem. I search more on internet and found the solution.

    https://shatter-box.com/knowledgebase/f ... ct-2-game/

    see the last comment.

    "Okay, I ended up uninstalling all the Firebase plugins and then shutting down C2. Restarted C2 and added the V3 API plugin, no problem.

    Of course then I added the Auth plugin and got an error but I think I know what is wrong there" from Fatesjoke

    and recently try the solution and really works, on windows 10 app works.

    -Duplicate my proyect

    -Take note the names of plugins from ,REX Authenticate, FirebaseApiV3, Query, and Firebase ( in my case "Firebase2")

    -Delete the plugins from proyect and eliminate from folder exports/html5/plugins.

    -Download again the plugins and paste again

    -Open the proyect. And add the plugins in the next order FirebaseApiV3, Authenticate, Firebase (with name "Firebase2") and Query

    -Close the proyect, and take all event sheets from duplicate proyect folder and paste on new.

    -Open the new proyect and fill the field of plugins.

    I try tomorrow on android and finish <img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt=":D" title="Very Happy">...i think.

    Again. Sorry about my Eng. <img src="{SMILIES_PATH}/icon_e_biggrin.gif" alt=":D" title="Very Happy">

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I export for android and the app working fine!

  • I can no longer access the .capx in the first post, so I can't investigate this report. Closing.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)