0 Favourites

168 to 169 update error screen

  • Problem Description

    I just oppened my previously working game after updating to new beta version 169 ...

    this is the ressulting error screen:

    ---------------------------

    Construct 2 Check failure

    ---------------------------

    Check failure! This is probably a bug:

    Action ID does not appear to exist in related plugin

    Condition: plugin->HasActionID(act_id)

    File: Projects\EventAction.cpp

    Line: 43

    Function: __cdecl EventAction::EventAction(class EventBlock &,class ObjectClass *,class BehaviorType *,int,class std::vector<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> >,class std::allocator<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> > > > &&,unsigned __int64)

    Build: release 169 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.

    ---------------------------

    Abort Retry Ignore

    ---------------------------

    I usually don't bother with reports as someone always gets them before me however... I've not see nthisone before.

    The game in question uses the following:

    browser plugin

    ludei's plugin (cocoon js)

    keyboard, touch...

    I have really no idea what causes this.

    I hope the screen info helps even a little.

    I tried returnign to 168 to no avail it gives me the same error even on the backup file... .

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • [update] after fiddling with it a while and backtracking to 168 the culprit is apparently the cocoon js plugin version I have.

    I literally had to go back and re-paste the whole thing for it to work again on the 168.

  • Closing as not a bug, I presume you are not using the official plugin and we do not support third party plugins.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)