0 Favourites

[r164.2]Normal use of AdjustHSL bug

  • Hey Ashley, I'm aware that the AdjustHSL effect is notorious for bugs and stuff, so sorry to 'bug' you about this (ahahahaha)

    Problem Description

    A range of colours get converted incorrectly when setting the "Hue" value around 70-100, and then previewing. (In the layout however, it looks correct, only when the game is run it looks incorrect.) Here's a screenshot of the Layout Editor and the undesired result:

    Attach a Capx

    Description of Capx

    There is 3 gradient Sprites which goes from black to red. 1st Sprite has 0 hue, 2nd has 50 hue, and 3rd has 80 hue.

    All of them look correct in the Layout editor, but when you hit preview (Node,Chrome, and firefox), the 3rd bar will have blue lines scattered through them.

    Steps to Reproduce Bug

    • Open Capx and notice the nice looking gradient bars
    • Run via Preview, notice the weird looking 3rd bar

    Observed Result

    Some colour gets turned blue when using AdjustHSL

    Expected Result

    What I see in the Layout editor

    Affected Browsers

    • Chrome: YES
    • FireFox: YES

    Operating System and Service Pack

    Tested on two different computers, same results.

    Windows 7 64-bit

    Construct 2 Version ID

    r164.2

  • Construct 3

    Buy Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Buy Now Construct 3 users don't see these ads
  • I've no idea how this could be fixed. As far as I know the HSL calculations are correct. There must be some weird floating point accuracy problem on the GPU. All I can recommend is not to use these settings. Closing as won't fix.

  • Ah I see, no problem! Thanks for checking it out. :p

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)