Images in Editor going hidden automatically, those are still there but i can't see them

  • Problem Description

    In my Layout Images are just disappearing. Something happening strange in this file.

    What is actually happening?

    when i open this file, after few time images are disappearing. To make this bug happen instant, I hold Ctrl and Mouse middle button scroll-up and scroll-down continuously for few seconds and all images gone. Actually they are hidden there if i click roughly over the hidden objects i can see there properties in the panel, When this thing is happen I can't see mouse dragging in editor and i can't see selection of any object. but they are still there

    What temporary solutions i found ?

    1) Restart Construct 2 but problem is still there, I caught this again.

    2) This is happening only in Layer named "UI" in this project, if i hide this layer, then i can see mouse dragging, i can see selection of object. and if i do unhide it, then again i can't see mouse dragging & Object's selection

    3) Few layers has effect "Set Color" if i delete this effect. images comes back and if i add that effect again, images go hide again.

    4) in the layer "UI" it has customized SpriteFont. if i reduce height of those Spritefont, every thing come back and if i increase height again they hidden, even if i delete those sprite font they come back.

    5) I have 5 layout in total, if i remove other 4 layouts and save and restart construct 2, Now this problem never happen again.

    So this is strange

    Attach a Capx

    dropbox.com/s/24u5733ui2g84pp/Error%20File.capx

    Description of Capx

    some objects and few layer with effect "Set Color" added

    Steps to Reproduce Bug

    Open linked capx.

    Open Game Layout

    Hold Ctrl and Mouse middle button and scroll up-down continuously for few second.

    Observed Result

    Objects in layer "UI" hiding automatically

    I can't see mouse dragging in editor and i can't see selection of any object. but they are still there

    Expected Result

    it should work normally

    Affected Browsers

    Chrome: (YES)

    FireFox: (NOT TESTED)

    Internet Explorer: (NOT TESTED)

    Operating System and Service Pack

    Windows 10 64 bit,

    Construct 2 Version ID

    R261 64-bit

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The project uses third party addons 'BHT Smart Random' and 'LiteTween'. Please remove these as per the bug report guidelines otherwise the report won't be investigated.

    The symptoms also sound a lot like a GPU driver bug, so it would be worth checking for an update.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)