[167.2] Debugger stepping bug

  • Problem Description

    Im not really sure if its a bug or its just the way it is. However noticed that if you pause the debugger. And minimize and maximize it again, it actually take a step forward even though its paused. (Using Node-web kit for previewing.) And don't think its related to 167.2 either.

    Description of Capx

    Its not CAPX related.

    Steps to Reproduce Bug

      [1] Pause the debugger [2] Minimize the debugger [3] Maximize the debugger

    Observed Result

    This is before minimizing.

    After maximizing again.

    Area marked with blue have changed even though it have been paused.

    Expected Result

    That it was paused.

    Affected Browsers

    • Chrome: (YES/NO)
    • FireFox: (YES/NO)
    • Internet Explorer: (YES/NO)

    Operating System and Service Pack

    Windows 7

    Construct 2 Version ID

    167.2

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Please provide a .capx. Your screenshots don't show an empty project so to reproduce what you are reporting we need the .capx you used for this report, or a new project which also reproduces it.

  • Here is a capx where you can recreate it.

    To test it, press the "Generate large dungeon" and while it is generating (The background is still white) press Pause in the debugger.

    In the left select the "List_dungeon_possible_tiles".

    Then minimize the window and maximize it again. And the items in the list have changed. If you keep minimizing and maximizing again you can see it actually drawing the dungeon each time.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)