How do I prevent my pixels from blurring?

  • Basically my pixels look all blurred sometimes, like if i stand on a specific point and if i move tiny amounts like one pixel at a time my sprite will blur, at some point it will start de-blurring and then become clear again.

    Like I'm basically standing almost on the same point but in the other picture i moved a bit and my sprite is blurred.

    What is causing this and is it possible to prevent it? How?

    Also like, what is generally the best idea how to set my project configuration settings? I want it to be fullscreen and still keep my pixels clear every time.

    edit: just wondering; if this question doesn't get answered at what point should repost it outside of the beginner questions forum?

  • Hi, here is an excerpt from the "Project primitives > Projects" chapter of the manual that I think will answer your question:

    [quote:y4vr6eny]Pixel rounding

    By default Construct 2 objects can be drawn at sub-pixel positions, e.g. (100.3, 200.8). If the browser is using linear filtering, this can make fine pixel art appear blurry. If Pixel rounding is set to On, Construct 2 objects round their position to a whole number before drawing, e.g. (100, 201). This prevents any blurring, and can also prevent "seams" appearing on grids of objects. Note this does not affect their actual X and Y co-ordinates, which can still be between pixels - it only affects where they are drawn on the screen.

    I hope this helps.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi, here is an excerpt from the "Project primitives > Projects" chapter of the manual that I think will answer your question:

    [quote:2exkvyg9]Pixel rounding

    By default Construct 2 objects can be drawn at sub-pixel positions, e.g. (100.3, 200.8). If the browser is using linear filtering, this can make fine pixel art appear blurry. If Pixel rounding is set to On, Construct 2 objects round their position to a whole number before drawing, e.g. (100, 201). This prevents any blurring, and can also prevent "seams" appearing on grids of objects. Note this does not affect their actual X and Y co-ordinates, which can still be between pixels - it only affects where they are drawn on the screen.

    I hope this helps.

    Thank you this totally fixed it!

  • Ok, new question. However this time the blurring is being caused by zooming in...

    I want my game to zoom in 200% whenever I have a dialogue and the box showing, this blurs my pixels again.

    Is there anything I can do to prevent this?

    I had a thought that I could just make all my art twice the size, as in draw everything with 4 pixels in a group instead of one, what i have now. But would this even work, since then I should make all my sprites half the size and I think that might blur it anyway??

    Any input? Heh.

    Here are screenshots;

  • Have you set in the 'configuration settings' Sampling to point? If not try if that helps.

  • Ah, it worked! Thank you!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)