Ultimate Ads - AdMob for C2 and C3 (Plugins)

  • 11.2019 Plugin works perfectly. Had some problems because C2 auto added <plugin name="cocoon-plugin-ads-android-admob" /> in the begining of plugins list of config.xml. You have to delete it and insert

    <plugin name="cocoon-plugin-ads-android-admob" spec="1.0.12"/> instead, then it will work perfectly.

    Tested on builds with phonegap and Cordova CLI.

  • Hi, I payed for this plugin but after following all the instructions it didn't work and never got a reply. I'm now using the Cordova Admob Plugin.

  • Hi, I payed for this plugin but after following all the instructions it didn't work and never got a reply. I'm now using the Cordova Admob Plugin.

    Hello, as mentioned in the post above yours, please edit the config.xml before building the APK.

    Change this line

    <plugin name="cocoon-plugin-ads-android-admob"/>

    To this line

    <plugin name="cocoon-plugin-ads-android-admob" spec="1.0.12"/>

  • > Hi, I payed for this plugin but after following all the instructions it didn't work and never got a reply. I'm now using the Cordova Admob Plugin.

    Hello, as mentioned in the post above yours, please edit the config.xml before building the APK.

    Change this line

    <plugin name="cocoon-plugin-ads-android-admob"/>

    To this line

    <plugin name="cocoon-plugin-ads-android-admob" spec="1.0.12"/>

    Toby R Hey interested in buying your mm_unloader plugin, But I'll like to know if it still works with the latest stable version of Construct 2

  • Toby R Hey interested in buying your mm_unloader plugin, But I'll like to know if it still works with the latest stable version of Construct 2

    Hello, yes the MM_Unloader works with every C2 version.

  • Hi, for more than 2 Years i builded my apks over cmd "Cordova build android" with no problems!

    I have the latests construct 2 build

    Today i buyed this plug-in

    Before i correctet the line i made a few apk tests

    After i corrected the line to <plugin name="cocoon-plugin-ads-android-admob" spec="1.0.12"/> i cannot build any apks!

    this is the first error with "cordova prepare android"

    Failed to install 'cocoon-plugin-ads-android-admob': Error: Cannot find module 'cordova-common'

    Require stack: ...

    and

    Failed to install 'cordova-plugin-ad-admob': CordovaError: Failed to fetch plugin github.com/cranberrygame/cordova-plugin-ad-admob-sdk via registry.

    this is the error when i write => cordova build android

    cordova-custom-config: Error loading dependencies for restoreBackups.js - ensure the plugin has been installed via cordova-fetch or run 'npm install cordova-custom-config': Cannot find module 'q'

    Require stack:

    - C:\Projekte\Construct2\Devil\Exports\Exports Cordova\90 - Kopie\plugins\cordova-custom-config\hooks\restoreBackups.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\hooks\HooksRunner.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\plugman\install.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\plugman\plugman.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\cordova-lib.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\src\help.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\src\cli.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\bin\cordova

    i would appreciate help, thx!

  • Hi, for more than 2 Years i builded my apks over cmd "Cordova build android" with no problems!

    I have the latests construct 2 build

    Today i buyed this plug-in

    Before i correctet the line i made a few apk tests

    After i corrected the line to <plugin name="cocoon-plugin-ads-android-admob" spec="1.0.12"/> i cannot build any apks!

    this is the first error with "cordova prepare android"

    Failed to install 'cocoon-plugin-ads-android-admob': Error: Cannot find module 'cordova-common'

    Require stack: ...

    and

    Failed to install 'cordova-plugin-ad-admob': CordovaError: Failed to fetch plugin github.com/cranberrygame/cordova-plugin-ad-admob-sdk via registry.

    this is the error when i write => cordova build android

    cordova-custom-config: Error loading dependencies for restoreBackups.js - ensure the plugin has been installed via cordova-fetch or run 'npm install cordova-custom-config': Cannot find module 'q'

    Require stack:

    - C:\Projekte\Construct2\Devil\Exports\Exports Cordova\90 - Kopie\plugins\cordova-custom-config\hooks\restoreBackups.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\hooks\HooksRunner.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\plugman\install.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\plugman\plugman.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\cordova-lib.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\src\help.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\src\cli.js

    - C:\Users\josef\AppData\Roaming\npm\node_modules\cordova\bin\cordova

    i would appreciate help, thx!

    Last night i reinstalled my "APK export environment" (android, cordova, npm ...)

    after that point i was abel again to build apks without this Plugin! (the plugin was still installed in c2 but i didnt use it in eventsheet in the construct 2 project).

    Then i used the plug-in in event sheet again , exported a project from construct2 (cordova) and i made "no" correction in xml file! I typed "Cordova peepare/build android". At this moment my apk environment didnt work again in general!!!!

    Sorry i am not a programmer, and sorry for my bad english.

    1 have a games in teststatus, a testgroup and i am worry about that this could be the end after a lot of work. :/

    thx

  • Hello,

    Please note that this error:

    Failed to install 'cordova-plugin-ad-admob': CordovaError: Failed to fetch plugin github.com/cranberrygame/cordova-plugin-ad-admob-sdk via registry.

    Has nothing to do with Ultimate Ads plugin. It's cranberrygame's Ads plugin. So I believe you have added two Ads plugins to your project, mine and Cranberrie's. Please remove the second one and try to build again. They probably conflict with each other while you don't need both.

    In case of further questions let me know.

    Good Luck!

  • Hi, I am using ultimate ads for iOS. I am using Cordova with the cocoon-plugin-ads-ios-admob plugin. Everything works fine, but there is a very big problem. Apple no longer skips Admob builds in the App Store with SDKs below 7.55.0. Tell me how to be? How to continue to publish iOS games with ADMOB?

  • Hi, I am using ultimate ads for iOS. I am using Cordova with the cocoon-plugin-ads-ios-admob plugin. Everything works fine, but there is a very big problem. Apple no longer skips Admob builds in the App Store with SDKs below 7.55.0. Tell me how to be? How to continue to publish iOS games with ADMOB?

    Hi, I am using it with my apps and I haven't seen any warning. Can you please link me to any official post about it?

    Also, I'm not sure what "no longer skips Admob builds" exactly means? Can you please rephrase it, or simply send me the official post.

  • Dear Publisher!

    In December last year, Apple announced that from April 2020, it will not be possible to publish applications that use UIWebView in the App Store, and from December 2020, corresponding updates for applications.

    All versions of the GMA SDK, starting with 7.55.0 (dated February 4, 2020), by default use WKWebview, not UIWebView.

    To ensure compliance with the requirements of the App Store, follow these steps:

    1) Update the GMA SDK to version 7.55.0 or later as soon as possible and apply it to the application.

    2) If you use Open Bidding or in-app mediation, check out the information below. It lists the minimum SDK versions of third-party ad networks that support WKWebView. Also make sure that the adapter versions match the SDK.

  • Dear Publisher!

    In December last year, Apple announced that from April 2020, it will not be possible to publish applications that use UIWebView in the App Store, and from December 2020, corresponding updates for applications.

    All versions of the GMA SDK, starting with 7.55.0 (dated February 4, 2020), by default use WKWebview, not UIWebView.

    To ensure compliance with the requirements of the App Store, follow these steps:

    1) Update the GMA SDK to version 7.55.0 or later as soon as possible and apply it to the application.

    2) If you use Open Bidding or in-app mediation, check out the information below. It lists the minimum SDK versions of third-party ad networks that support WKWebView. Also make sure that the adapter versions match the SDK.

    Thank you for the details. I will investigate and make an update if needed. Will post an announcement soon.

  • I will be very happy if you redo the plugin. I need it very much. This is very important to everyone who makes games for iOS. Write if there is news. thank

  • Hi,

    please i need some help to understand it better.

    After i published my app in Google Play i tried to add "Ultimate ads"

    I watched the whole tutorial but it still did not work for me.

    So i made a small new project and a little unsigned .apk with only the "Ultimate ads" feature

    C2 sheet

    - on start of layout => load banner

    - If load => show banner

    Testmode is enabled

    Banner id is from google admob

    C2 export to cordova

    - cmd: prepare cordova android

    - edit xml file by adding

    - <plugin name="cocoon-plugin-ads-android-admob" spec="https://github.com/MBuchalik/cordova-build-architecture.git#v1.0.1" source="git" />

    then cmd: cordova build android

    I tested it directly on mobile phone and it doesnt load the test banner

    any ideas?

    Thanx :)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi,

    please i need some help to understand it better.

    Hi,

    I never tried the way you edit config.xml. But please try directly from NPM instead of Git so add just this instead:

    <plugin name="cocoon-plugin-ads-android-admob" spec="^1.0.0"/>

    Let me know if it works. BTW it's best to ping me on my discord for a quick reply (https://discord.gg/ayRypRH)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)