Construct2&3 Cordova Plugins (Plugins)

  • Hi good morning

    I was using cramberry chartboost plugin. But it stopped working.

    Chartboost has updated and it is no longer working integration.

    Do you have any plugins for chartboost?

    I can buy.

  • Hi I am facing an error when using the cordova-file-plugin in Construct 2. When I export the cordova plugin on Phonegap I get error when creating the APK. This is the build log :

    Build Date: 2018-07-22 19:14:32 +0000

    --------------------------------------------------------------------------------

    PLUGIN OUTPUT

    --------------------------------------------------------------------------------

    Fetching plugin "cordova-custom-config" via npm

    Installing "cordova-custom-config" at "5.0.2" for android

    Fetching plugin "cordova-plugin-file" via npm

    Installing "cordova-plugin-file" at "6.0.1" for android

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Skipping 'cordova-plugin-file' for android

    Fetching plugin "cordova-plugin-file-transfer" via npm

    Installing "cordova-plugin-file-transfer" at "1.7.1" for android

    Plugin dependency "cordova-plugin-file@6.0.1" already fetched, using that version.

    Installing "cordova-plugin-file" at "6.0.1" for android

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Skipping 'cordova-plugin-file' for android

    Fetching plugin "cordova-plugin-statusbar" via npm

    Installing "cordova-plugin-statusbar" at "2.4.2" for android

    Fetching plugin "cordova-plugin-whitelist" via npm

    Installing "cordova-plugin-whitelist" at "1.3.3" for android

    This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.

    Fetching plugin "cordova-plugin-wkwebview-engine" via npm

    Installing "cordova-plugin-wkwebview-engine" at "1.1.4" for android

    WARNING: Overriding compileSdkVersion from android-25 (default) to android-26

    WARNING: This is unsupported, please consider updating your phonegap version instead

    --------------------------------------------------------------------------------

    PROJECT PROPERTIES

    --------------------------------------------------------------------------------

    # This file is automatically generated by Android Tools.

    # Do not modify this file -- YOUR CHANGES WILL BE ERASED!

    #

    # This file must be checked in Version Control Systems.

    #

    # To customize properties used by the Ant build system edit

    # "ant.properties", and override values to adapt the script to your

    # project structure.

    #

    # To enable ProGuard to shrink and obfuscate your code, uncomment this (available properties: sdk.dir, user.home):

    #proguard.config=${sdk.dir}/tools/proguard/proguard-android.txt:proguard-project.txt

    # Project target.

    target=android-26

    android.library.reference.1=CordovaLib

    --------------------------------------------------------------------------------

    COMPILE OUTPUT

    --------------------------------------------------------------------------------

    Subproject Path: CordovaLib

    Running command: /project/gradlew cdvBuildDebug -b /project/build.gradle -Dorg.gradle.daemon=true -Dorg.gradle.jvmargs=-Xmx2048m -Pandroid.useDeprecatedNdk=true

    The Task.leftShift(Closure) method has been deprecated and is scheduled to be removed in Gradle 5.0. Please use Task.doLast(Action) instead.

    at build_bg6b9nfbtebrt3ot5g1ccvqoz.run(/project/build.gradle:137)

    The JavaCompile.setDependencyCacheDir() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    Incremental java compilation is an incubating feature.

    The TaskInputs.source(Object) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use TaskInputs.file(Object).skipWhenEmpty() instead.

    The ProjectDependency.getProjectConfiguration() method has been deprecated and is scheduled to be removed in Gradle 4.0.

    ModuleDependency.getConfiguration() has been deprecated and is scheduled to be removed in Gradle 4.0. Use ModuleDependency.getTargetConfiguration() instead.

    :preBuild UP-TO-DATE

    :preDebugBuild UP-TO-DATE

    :checkDebugManifest

    :CordovaLib:preBuild UP-TO-DATE

    :CordovaLib:preDebugBuild UP-TO-DATE

    :CordovaLib:checkDebugManifest

    :CordovaLib:prepareDebugDependencies

    :CordovaLib:compileDebugAidl

    :CordovaLib:compileDebugNdk UP-TO-DATE

    :CordovaLib:compileLint

    :CordovaLib:copyDebugLint UP-TO-DATE

    :CordovaLib:mergeDebugShaders

    :CordovaLib:compileDebugShaders

    :CordovaLib:generateDebugAssets

    :CordovaLib:mergeDebugAssets

    :CordovaLib:mergeDebugProguardFiles

    :CordovaLib:packageDebugRenderscript UP-TO-DATE

    :CordovaLib:compileDebugRenderscript

    :CordovaLib:generateDebugResValues

    :CordovaLib:generateDebugResources

    :CordovaLib:packageDebugResources

    :CordovaLib:processDebugManifest

    :CordovaLib:generateDebugBuildConfig

    :CordovaLib:processDebugResources

    :CordovaLib:generateDebugSources

    :CordovaLib:incrementalDebugJavaCompilationSafeguard

    :CordovaLib:compileDebugJavaWithJavac

    :CordovaLib:compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    :CordovaLib:processDebugJavaRes UP-TO-DATE

    :CordovaLib:transformResourcesWithMergeJavaResForDebug

    :CordovaLib:transformClassesAndResourcesWithSyncLibJarsForDebug

    :CordovaLib:mergeDebugJniLibFolders

    :CordovaLib:transformNative_libsWithMergeJniLibsForDebug

    :CordovaLib:transformNative_libsWithSyncJniLibsForDebug

    :CordovaLib:bundleDebug

    :prepareProjectCordovaLibUnspecifiedDebugLibrary

    :prepareDebugDependencies

    :compileDebugAidl

    :compileDebugRenderscript

    :generateDebugBuildConfig

    :generateDebugResValues

    :generateDebugResources

    :mergeDebugResources

    :processDebugManifest

    :processDebugResources

    :generateDebugSources

    :incrementalDebugJavaCompilationSafeguard

    :compileDebugJavaWithJavac

    :compileDebugJavaWithJavac - is not incremental (e.g. outputs have changed, no previous execution, etc.).

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:49: error: package org.apache.cordova.file does not exist

    import org.apache.cordova.file.FileUtils;

    ^

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:851: error: cannot find symbol

    FileUtils filePlugin = (FileUtils) pm.getPlugin("File");

    ^

    symbol: class FileUtils

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:851: error: cannot find symbol

    FileUtils filePlugin = (FileUtils) pm.getPlugin("File");

    ^

    symbol: class FileUtils

    Note: /project/src/org/apache/cordova/filetransfer/FileTransfer.java uses unchecked or unsafe operations.

    Note: Recompile with -Xlint:unchecked for details.

    3 errors

    :compileDebugJavaWithJavac FAILED

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':compileDebugJavaWithJavac'.

    Compilation failed; see the compiler error output for details.

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    BUILD FAILED

    Total time: 7.61 secs

    Command finished with error code 1: /project/gradlew cdvBuildDebug,-b,/project/build.gradle,-Dorg.gradle.daemon=true,-Dorg.gradle.jvmargs=-Xmx2048m,-Pandroid.useDeprecatedNdk=true

    Error: /project/gradlew: Command failed with exit code 1 Error output:

    Note: Some input files use or override a deprecated API.

    Note: Recompile with -Xlint:deprecation for details.

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:49: error: package org.apache.cordova.file does not exist

    import org.apache.cordova.file.FileUtils;

    ^

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:851: error: cannot find symbol

    FileUtils filePlugin = (FileUtils) pm.getPlugin("File");

    ^

    symbol: class FileUtils

    /project/src/org/apache/cordova/filetransfer/FileTransfer.java:851: error: cannot find symbol

    FileUtils filePlugin = (FileUtils) pm.getPlugin("File");

    ^

    symbol: class FileUtils

    Note: /project/src/org/apache/cordova/filetransfer/FileTransfer.java uses unchecked or unsafe operations.

    Note: Recompile with -Xlint:unchecked for details.

    3 errors

    FAILURE: Build failed with an exception.

    * What went wrong:

    Execution failed for task ':compileDebugJavaWithJavac'.

    Compilation failed; see the compiler error output for details.

    * Try:

    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

    at ChildProcess.whenDone (/project/cordova/node_modules/cordova-common/src/superspawn.js:169:23)

    at emitTwo (events.js:106:13)

    at ChildProcess.emit (events.js:191:7)

    at maybeClose (internal/child_process.js:877:16)

    at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)

  • Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0

    Research this, it's telling you where to start

  • Thanks for your reply, that's the first thing I did before posting it over here :)

    Any update regarding where we could download the plugin with the latest version would be very helpful, thanks!

  • I tried the plugins but they do not work .. despite follow all the steps

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Unity Ads not working on iOS. Construct 3, export as Xcode project.

  • I'm sorry to say that the plugin Developer is dead he is no more That's why we have no updates I highly Request to scirra please remove These plugins from scirra store People Are Wasting money without earning like me

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)