Alex's Platformer Template (Templates)

  • v1.2 works with latest Construct2 (tested on r206)!

    Alex's Platformer Template — Now for sale in the Scirra Store!

    https://www.scirra.com/store/royalty-fr ... mplate-406

    Platformer Movement TemplateIncludes features:rope grab, climb, slide, dropledge hang, climb, dropwall jump, slideanimations that correlate to all these actions.Easy rope creation (just place one object "alexropeOrigin" that has instance variables for number of rope segments, length, slippery boolean(if rope should be slippery), etc).Also add "alexropeEnd" objects if you want the end of the rope attached, and match the rope instance variable to the ropeID instance variable that is set in the alexropeOrigin object.UpdatesBuyers will be allowed free access to any new versions of this product.

    Use this topic to leave comments, ask questions and talk about Alex's Platformer Template

  • Update to the template is now approved/available!

    http://youtu.be/8K90nH7_oeM

    I fixed a couple bugs from previous version. Also included a grappling hook. The grappling hook is simple, and more of an experimental feature at the moment.

    The big addition is that now the player can now shoot projectiles and there are animation states that go along with them.

    current projectile types:

    • single shot,
    • bouncy,
    • laser,
    • instant,
    • arced,
    • boomerang,
    • flamethrower

    These can be enabled/disabled, and player can cycle through them, etc.

    also with option of shooting towards mouse (360 degrees), or restricted to 45 degrees via keyboard/buttons.

    Next, I plan to work on implementing simple enemy types that you'll be able to shoot.

  • Does this come with the same grappling hook that is available as Alex's Grappling Hook?

  • Does this come with the same grappling hook that is available as Alex's Grappling Hook?

    Zebbi , no, the grappling hook in the grappling hook template works differently. The grappling hook template is more straight looking and doesn't rely on as many physics objects. It allows more predictable swinging results in my opinion.

  • Excellent, thanks for the clarification!

  • that swing on the rope looks COOL

  • http://a.pomf.se/cnlmie.png

    Anyone else getting this error?

    Is it something that the seller can fix or is it to do with C2 update 197.

    Both the version I have built my game on top and the original untouched version is giving me this.

  • Discmach , I would first check to see if the project is still using the same physics engine (box2d web), by checking the project settings. I haven't updated to the 197 yet. The issue would have to be with construct2 since the platform template doesn't use any third party extensions. So if it is using the correct physics engine, then I would show the error message to scirra and hopefully they will fix it.

  • maybe Ashley can give us some information on this?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can't help unless you post a bug report following all the guidelines.

  • I have the same error as Dismach . Alex Please correct the error because it does not work .. Construct r206

  • I can't fix it without knowing what the issue is. Since scirra updated the physics, it seems it must have introduced some issues. So they'll need to provide us with some info on how to ensure previous projects work on the latest version of Construct 2.

  • I have the same error as Dismach . Alex Please correct the error because it does not work .. Construct r206

    Movie , Discmach , I've found the event that causes it to crash. I'll try to fix it. I'll let you know when it is fixed.

  • Thanks in advance .

  • OKAY.. I fixed the issue.

    I've uploaded a v1.2 capx

    It should be made available soon once it is approved.

    I also found a bug with Construct 2 that I will report, but the template will work with latest construct2, and with nw.js .. If you are using an older version of node webkit, you may want to update that.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)