Any way to increase responsiveness of construct 2?

  • Hi iv'e been using construct for a game for a while now. pumped 600+ hours into it and for about a month now the engine becomes very unresponsive.

    When I double click events they take a short while to open or I have to click the construct window tab at the bottom for it to show up.

    Everything can become really unresponsive and minimizing and maximizing the window is needed to refresh black screens.

    It happens fairly often now usually every session, does anyone know the main reason I have these problems?

    Perhaps some reasons may be:

    I have got a fair few of the plugins from the forums.

    I have 50 layouts up to yet.

    The game runs fine ingame it's just when making it with construct 2 I get the problems.

  • How many Layouts and Event Sheets have you got open?

    How many Objects have you got on the Layouts?

  • if open you mean tabs at the top I usually only have 4-5 open at once.

    layout objects wise changes per map but around 30 different objects per map and lots of instances of most. Maybe a few hundred on some maps.

  • I have also come across this problem...

    C2 on some occasions seems to lag, if I click the action or event box there is a 1-2sec delay before it opens, if I start typing in an input box there is around a 1/4sec delay between each letter appearing on the screen.

    I then have to minimize C2 and maximize it to get it to return back to normal.

    Unfortunately I haven't been unable to find the cause of this problem.

    It isn't connected to the size of the project either, only yesterday I was making a small prototype game approx 20 stationary sprites and 60 events and had the same problem...

    At least the minimize maximize trick works

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Black screens ? Sounds like graphic driver issues.

    Update yours and make sure to use a decent graphic card and not just graphic chipset from the motherboard.

  • If you can reproduce any issue reliably, please submit it as a bug report and we'll take a look. Perhaps the latest betas are better as well?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)