[plugin] fade in/fade out audio

  • rexrainbow - is there a way to fade out music if the timescale is 0? I'm trying to fade it out from a pause menu, and it doesn't start the fade until the next layout starts (due to the timescale being reset to 1).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ome6a1717

    I did not test it, sorry I have no idea, you might try by yourself.

  • Hi rexrainbow ,

    For your information, I encountered the same kind of bug we were talking 5 replies above this one while using the "pause" with fade out functionality of Audio Helper. It works fine with "stop", but "pause" still make the tag to be shut down forever.

    Cheers and thanks a lot for your hard work!

  • Rable

    Pause with fade-out, resume with fade-in are worked in this capx, please provide a simple capx for your issue.

  • rexrainbow

    Thanks for your reply.

    After investigating, the problem only arises when resuming with the built-in audio plug-in and setting the sound at 0dB. In that case, it seems impossible to play the music again with the built-in audio plug-in

    When resuming with the audiohelper plug-in, everything seems to work just fine.

    Here is a capx if you're interested. But I'll just use the audiohelper plug-in to resume from now on, so no urgent fix needed as far as I'm concerned.

  • Rable

    Current volume will be saved if calling pause action of my audio help plugin, this saved volume value will be used when resume action of my audio help plugin.

    I had updated this audio helper plugin, now it will fade-in to 1 db if no saved volume valued found (i.e. pausing by official audio plugin)

  • rexrainbow

    I updated the plug-in (only the runtime.js has been updated if I'm correct) and tried the capx I submitted in my previous reply, but it's still not working for me.

  • rexrainbow

    Hi, I hope this topic isn't too old, I discovered recently your audio helper plugin and it works well, except for the "resume" action which results in this error :

    i.imgur.com/pSkyzYm.png

    It tested it with the example capx file and NW.JS browser (as I export almost all of my project on hat browser), I don't know if it is related or not;

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)