[Plugin] Windows Phone Updated - New Tutorial!

  • SuperMoi do you have the game set to test mode in C2 before exporting it as a WP8 app?

  • I just can't understand what on earth is wrong with my submitted xap.. I try to submit it but it fails it three ways. 1. They say the name is generic "WindowsPhonePlugin". No it is not. When I test it, the name shows up just fine. 2. Icons are the default ones. No they are not. When testing the icons are the ones I made myself, even the pinned ones. 3. The game fails to launch. Well not on my Lumia 920 (that is one of their test devices) It works great. So it just that Visual Studio won't build the release xap right or what? Does anyone have any tips on this?

    EDIT: I may have found a way to fix my problem. I built my release .xap with Build -> Batch Build -> Release

  • L3mon Did that resolve the issues?

  • BluePhaze / L3mon On Visual Studio, click on the Solution, you can rename the name there. Then click on the Actual Name -> Project Properties and you can also change the name there. With those 2 changes, you should notice that the name was changed from WindowsPhonePlugin to whatever you want.

    Please note, you also have to change the WMAppManifest.xml

    That should work. Do not replace all the WindowsPhonePlugin, because you will break the code (as you already know).

    Hope this helps. This plugin is great! :)

  • BluePhaze Well I guess it did. Because I didn't really have any issues with the naming. I thought I did but as gfigueroa said you just need to change your information in WAAppManifest and that's it. It's just that for some reason Visual Studio didn't build my release .xap when I simply pressed build solution.

  • L3mon You have to make sure you set the build option to Release build and also get it from the right directory, the debug and release builds go to different directories.

  • BluePhaze Yeah I learned that now. Go check you Polydodge and DoubleSpeed on WP Marketplace ;)

  • Hi WPGamer did you ever solve the issues with the images all been displayed overlapping in the top left corner?

    I have the same issue here when using the plugin project or just the files

    MainPage.xaml,

    MainPage.xaml.cs,

    Index.html

    App.xaml.cs

    This issues does not occur in the standard C2 export.

    Cheers

    Darryl

  • Found it, if any one else is having the same issue would recommend replacing index.html with the one that the C2 Export Generated. This sorted the issue for me.

  • I don't know if anyone else has experienced this but I have on several projects so I just thought I'd share this little thing.

    When using back button put a little wait time (like 0.1s) before going to previous layout or quitting. Because when I didn't put any wait time in there and just tried to go to previous layout it usually just closed the whole game. I guess it was just still registering the back button or something like that..

    Or am I the only one with this (small) problem?

  • L3mon can you repro and send me an exported project?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Someone can help me with the integration of MS Pubcenter ads in my 2 Windows phone Games??

    Can i integrate it? There are any tutorial about it?

    Please Help me!!!!

    (I use the thehen plugin in my game)

  • Hi, I have IE11 and MS Visual Studio Express 2013 and Construct2-r163 installed on my desktop (OS- Windows7 service pack-1). I exported my Construct2 project on Windows Phone 8 platform and double clicked Microsoft Visual Studio Solution (.sln) file in the exported folder. But MS Express was unable to open the file showing the dialog as:

    Unsupported

    This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them.

    For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK.

    • Testapp, "C:\Users\Asit\Desktop\Testapp\Testapp.csproj"

    Please suggest what to do .

  • Asit you need the right version of visual Studio. If you are using express look for the version that specifies windows phone.

  • Hey great thanks for this plugin man

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)