[plugin] 3D using Copperlicht

  • Thanks, it is a great help this plugin.

  • wildmedia is your Construct2 layout set to "transparent"?

    Im having the same issue but i cant find where to set the Layout to Transparent.

    Anyone got the testroom.capx working fine?

    Thanks!

  • Fersis , the transparency setting should be in your layer properties (https://www.scirra.com/manual/85/layers). I only had one layer, so I only had to set one layer to "transparent".

  • Fersis , the transparency setting should be in your layer properties (). I only had one layer, so I only had to set one layer to "transparent".

    juantar please, help me.

    How do you make a scene ''room2.ccbjs''? You used the program "CopperCube"?

    I'm doing a scene in "CopperCube", but it does not work.

    Can you please upload here a model "room2.ccbjs" from testroom?

    thanks in advance

  • awesome!!!!good job...keep working on it

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I ignored

    I can not help with the creation of 3D scenes in CooperCube

    Жалко, что никто не подсказал мне...

  • copperlich is working fine when exported to html in my ftp, its really not the case with the other plugin Q3D, nothing seems to work when exported in html5

    but copperlich is really expensive the "basic" version

  • this "test" game allways freeze after 5s.......

  • The Q3D plugin is probably better written than this one. The freeze you are experiencing might be due to a lot of vectors being created. Out of ignorance at tge time, I did not apply some javacsript best practices on memory management.

    Reken : yes, I created the scene using coppecube (the version from 2013 I think). I don't have the latest version of coppercube (expensive) but I would guess the problems you are seeing are due to the copperlich.js library used in the plugin being too old for your scene. If you know javascript, You could try replacing the copperlicht library in the plugin with the library that gets exported in your coppercube scene (i think the file is called copperlicht.js)

  • Reken : yes, I created the scene using coppecube (the version from 2013 I think). I don't have the latest version of coppercube (expensive) but I would guess the problems you are seeing are due to the copperlich.js library used in the plugin being too old for your scene. If you know javascript, You could try replacing the copperlicht library in the plugin with the library that gets exported in your coppercube scene (i think the file is called copperlicht.js)

    juantar thanks for the reply

    What's your version coppercube? (I used to 5.0.2 (DEMO) )

  • I don't have the exact version with me, ( I think I uninstalled it). It was the version back in mid 2012. So about 2 years ago.

  • I don't have the exact version with me, ( I think I uninstalled it). It was the version back in mid 2012. So about 2 years ago.

    I understand you

    Thank you very much for your help

    ????, ??? ??, ??? ????????? ??????? juantar

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)