[Behavior] Sprite Effects & inject Text on Sprite

  • What values does the Tint option take?

    is it from 0 to 1?

    And how can i map 0-255 rgb colours to represent them in Tint values?

  • I am SAVING the sprite at the very start.

    Then every time I hit a button to colorize using hue I RESET and colorize.

    This works great in IE and Firefox.

    But it does not work in Chrome & Safari.

    I had to disable WebGL in C2.

    any ideas?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I guess you�re working on it, but just for the note, the simple blur effect doesn�t work on chrome or firefox ;]

  • bjadams : it's untested with WebGL, because it's faster to use a shader in WebGL than iterate over a texture with JS. I have a plugin using WebGL for image effects, but it's not released yet.

    sheepy : I think it's related to the new 'Spritesheet' function of C2. I didn't tested it for the moment.

  • Hi.

    just an FYI, I'm getting this when I start up c2

    <img src="http://content.screencast.com/users/crhatfield/folders/Jing/media/901b517f-2e1f-4e4f-a607-e21e45a9f06e/2012-06-06_0301.png" border="0" />

    just now downloaded fresh copy, extracted and copy/pasted them into that folder in plugins, and still getting error *shrug*

    • Cecil
  • It's no problem to disable WebGL for this one project i am doing.

    The problem is that I am SAVING the sprite at the very start.

    Then every time I hit a button to colorize using hue I RESET and colorize.

    This works great in IE and Firefox. But it does not work in Chrome & Safari.

    Any ideas?

  • I am getting the same error as crhatfield. If anyone could advise me on how to fix it it would be greatly appreciated.

    Sincerely,

    Yeti Kart Racer

  • I am really stuck. I was really hoping that this plugin could get me out of misery!!!!

    Then every time I hit a button to colorize using hue I RESET and colorize.

    I cannot get it to work properly in Chrome & Safari!!! Curiously it works in IE (usually its the other way round)!!!!

  • bjadams : as soon as I have the time to do it, I'll update the plugin.

  • Thanks a lot PODE

  • on the new version of Chrome, the Tint effect works the first time round, then when you do a RESET it restores the sprite back to normal, but when you do another TINT on the same sprite, it does not work. Same problem on Safari.

    Works GREAT on Firefox and IE9 :)

  • I have confirmed that the problem is not the TINT action but the RESET.

    Unfortunately I am not familiar enough with canvas to fix this myself :(

  • any updates?

  • bjadams : I'm out of town for two weeks (holidays). I still read the forum, but I'm only going to be able to fix the code in two weeks, sorry.

  • no problem Pode, really looking forward for the fixed version of this GREAT plugin.

    Enjoy your holidays!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)