Running Construct in a VM?

This forum is currently in read-only mode.
  • Hello,

    Its been a while since I've stopped by the Scirra community, so its great to be back! Actually, the main reason I've stopped using Construct for the past year or so was because I migrated 100% over to Linux which Construct has yet to support (and probably never will unless someone, such as myself, bothers to port it....)

    On that note, I recently picked up a copy of Windows XP and put it on VirtualBox 3.2.10 (proprietary) under 64 bit Linux running a 2.6.35-22-generic kernel. Installation and the such was successful for everything (including Scirra Construct and DirectX) but I hit a wall when trying to create a new project in Construct: it claims that it does not have enough video memory to be able to view the editor. I had allocated 128 mb of video memory in my VM and also enabled both 2D and 3D acceleration and installed the VirtualBox client addons for Windows XP.

    Any ideas?

    Thanks!

    EDIT: I just realized that this post is in the wrong board.... Should I delete and repost in the correct location, or can one of you mods handle it for me? Thank you!

  • Did you allocate 128 megabits or 128 megabytes off memory?.

  • Moved to Help & Support using Construct.

  • I can't get it running on Wine. Whenever I open the app, nothing happens, not even an error.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I can't get it running on Wine. Whenever I open the app, nothing happens, not even an error.

    It won't work in Wine because Construct requires the latest version of DirectX. Running it in a VM works to a slight degree.

    Did you allocate 128 megabits or 128 megabytes off memory?.

    I believe I allocated 128 megabytes but as VirtualBox only lists it as "MB" I am not so sure...

  • Construct (the app) and all Construct games work fine for me in a Windows Xp Sp2 VM with 512 MB ram. I am using VMware though.

    Maybe you need more RAM?

  • Construct (the app) and all Construct games work fine for me in a Windows Xp Sp2 VM with 512 MB ram. I am using VMware though.

    Maybe you need more RAM?

    I allocated 2 GB of RAM so that shouldn't be the problem... I backed up my Linux partitions and I installed Windows (eww....) as I had a couple other things I might need it for, but I will probably put it in a VM as well. Are you using VMware Player? Thanks!

  • Sounds like it is a VirtualBox issue then. I am using VMWare Workstation with 3D support enabled. However, Vmware player/Vmware Server should work equally well.

  • You should try on a VM created using another software. Maybe it'd work.

    Sorry, I'm not on Linux right now so I can't look for the software that exist.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)