Really bad OGG playback.

This forum is currently in read-only mode.
  • Listen to this:

    http://www.konjak.org/echo.mp3

    The first part of it is the OGG played externally through Winamp, the second part is the same file being played by XAudio2.

    There's a definite "doubling" effect, creating a nasty echo. When I tried earlier it even muffled the track. Is there anything I can do about this?

  • I've sometimes noticed that with normal .wav files too (I don't usually use .ogg), it seems to sometimes randomly play it "muffled" on occasions.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I guess this is the wrong board, sorry.

  • Moved to help/tech support.

    What events are you using to play the OGG? It plays using the official OGG Vorbis decoder so it doesn't use anything special or different. You might have accidentally run the 'play' event twice.

  • Bah, I had two instances of a global XAudio2, removing one seemed to fix the muffle, but there's still a slighty echoing effect to all tracks. Not the exact same as my example MP3, but playing the files back-to-back you can still hear a slight reverb from Construct.

    EDIT: http://www.konjak.org/echo2.mp3

    The current echo side-effect makes the feel of music change quite a lot, so I hope it's fixable somehow... It's the difference of making a studio recording and making one in a big empty room.

    The music plays on a looping reserved channel which was made reserved at start of layout.

  • Further listening has turned up stuff that it seems XAudio2 likes to increase the volume and "flatten out" the track. Like if I have a song with normally quiet treble at the start (like just a brush percussion) it increases its volume until the next layer of melody comes in, where it then "evens out" the volume between the overlapping melodies.

    This hasn't got anything to do with the .OGG file itself, as listening to it outside Construct there's no "strange reverb" or volume planing. I don't know if this has something to do with DirectX, or if it can be improved, because right now it's really ruining my music's feel and balance...

  • It evidently happens to all sounds, I notice, but I found the culprit: the "limiter" property. Turning it off I get no strange reverberation. Might be good to know if others come and bother you as much as me. Changing any of the parameters regarding the limiter doesn't change the reverb effect.

    What are the repercussions (no pun intended) to turning it off? Is it just distortion?

  • Ah, the limiter, of course. It's intended for sound effects. If you play a lot of sound effects at once, you'll clip the maximum level of the output and hear nasty distortion. If you're only playing music that's fine, but you might have problems mixing music and sound effects.

    It only affects sounds played on channels - if you use Play Music, it isn't affected by the limiter even when it's on. But you'll need an OGG decoder for Directshow to play OGGs that way.

  • I think I can balance sounds for now... I don't want a decoder that I have to force on people later.

  • Ah right. I thought it sounded like a limiter. In my opinion, limiters of any kind are only useful when you can adjust every single setting of it.

    I noticed this weird audio thing as well. Thanks for bringing up the subject and for the solution

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)