Problem with plasma object

This forum is currently in read-only mode.
  • I'm using pixel shaders and the plasma objects for my game. On my computer, the plasma object creates tiny red flames around an object and they look awesome. On my friend's computer it creates a massive white/red additive looking circle that takes up half the screen and it looks awful.

    I figured it has something to do with his graphics card, but we've been testing stuff out and the pixel shaders work fine on his computer so I don't see what the problem is.

    Any ideas?

    He's using a pavillion tx200 tablet..if that helps.

    Also, so I don't have to make another post, how do I compare to the amount of said objects currently in the layout? I can't find it anywhere. For example: "Number of (object) is greater than 0" or "None of (object) exists"

    Thanks!

  • well to begin narrowing down, and to clarify

    pixel shaders are separate from plasma, if the plasma doesn't have an effect on it, pixel shaders shouldn't be an issue.

    the plasma doesn't have an effect added right?

    Also, are you absolutely sure that you have the same version of Construct?

    As for the second question, generally, if you have more than one unrelated question, it's probably best to just make two separate posts, as long as you're not flooding the board with 5 posts at a time. This will make it easier for anyone having the same question/problem as you to find your question, and also let's people who might have an answer see that you asked it.

    There are two expressions that may be of interest.

    TotalObjects - which give's you the total number of objects (of any type) currently in the layout,

    and CountMatching(OID or ObjectName) gives you the number of a certain type of object, like CountMatching("BadGuySprite"), will tell you how many BadGuySprites match that event. If you use it with an Always condition, it will give you the total amount of BadGuySprites currently on the layout

    CountMatching and TotalObjects are System Expressions, and you get a list to choose from if you doubleclick the system icon while setting the parameters in any new action, condition, or expression

  • Thanks for the help so far!

    I'm still unable to figure out why the plasma object is acting up on my friends comp For starters, no there aren't any effects added to it. Secondly, I sent him an .exe. He doesn't use Construct, I was just showing him what the plasma object does.

    All I did was make a plasma object, stretch it out and put it over the layout, then make the event:

    Always: (Plasma) Set subtract pattern angle to timer/100

    Paste object(s) into plasma

    He sent me a video this time and what happens is instead of "flames" he gets a distorted white glob that grows and grows until it fills up the entire screen. It seems like his computer is missing something needed to properly display the plasma object's effects, but it's not like he has an old computer or something sooo I'm completely stumped.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Rendering can look wrong if the graphics card drivers are old or buggy. Try updating the drivers on your friend's machine.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)