Picture Editor

This forum is currently in read-only mode.
  • Hello!

    I've spent a few hours with Construct, and I am quite impressed with the feature set. One thing that prevents me from using this however are the frequent crashes--the main one being when I try to access the Picture Editor. By opening and closing the Picture Editor roughly 6 times to edit a Sprite, the program hangs and I have to kill the process. That is if I am trying to access the Picture Editor directly by clicking on the "Edit" link in the Sprite's common properties. Usually if I open the Picture Editor from the Animation Bar once or only a few times, a crash occurs, and I sometimes receive a "R6025 pure virtual function call" error.

    Not being able to edit pictures without causing a crash is my main concern at the moment. Thanks.

  • Are you using the latest version (0.86.2)? I think we fixed a bug like this a build or two ago. Also, the 'Edit' link in Sprite's Common properties just edits the icon, not the sprite itself. I just tried opening the picture editor 10 times or so using both the edit icon link and the animator bar and it works OK here. Do you have a .cap file with steps to reliably reproduce this? Can you send the .cap to ashley@scirra.com if so?

  • Well, now the file just seems to be corrupted. When I try to open it, I receive "an attempt was made to access an unnamed file past its end". <img src="{SMILIES_PATH}/icon_eek.gif" alt=":shock:" title="Shocked" />

    But if I create a new, empty Construct project, insert a Sprite object, close the Picture Editor after it first pops up automatically, and then reopen the Picture Editor 5 times, the program crashes, and I sometimes receive the "pure virtual function call" message. This happens when opening the Picture Editor from the Edit links or from the Animation Bar.

    I am using version 0.86.2.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm using the same version. Did exactly as you described but I could reopen the empty sprite 12 times without any problems. On the 13th try Construct crashed and I had to close it with ctrl+alt+del.

    No message was shown.

    So I can confirm the bug partially. <img src="{SMILIES_PATH}/icon_smile.gif" alt=":)" title="Smile" />

  • I'm still getting this crash as well. I can open the image editor ten times before it crashes and gives the "pure virtual function call" message. This is in 0.86.2

    I hadn't noticed before because I haven't been using Construct that much lately, I've been concentrating on finishing my current game in MMF <img src="{SMILIES_PATH}/icon_redface.gif" alt=":oops:" title="Embarassed" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)