For some reason my control code won't work

This forum is currently in read-only mode.
  • I'm trying to do this code for switching players and I have my code set up like this.

    I'm looking through the debug and it isn't showing that I'm even pressing a button(which I base on because the value isn't adding) Perhaps I'm not doing the code for button presses right.

    I've checked through the platforming school .cap and I can't understand what I'm doing wrong.

    I've edited the image so it says "pressed" instead of down.

    This isn't the problem I'm having the problem is the code for pressing the button just isn't working. I even tried saying On"Switch" pressed > Player1: Jump and that didn't do anything either. I also tried doing it with keyboard controls and it didn't work.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It won't work like you expect if you use the 'control is down' condition. As you say it will keep adding 1 as long as it held, which will definitely mess it up, so you definitely want to use the 'on control pressed' condition.

    Maybe if you post a .cap people can investigate what you've done more easily.

  • I think I found out what's going on here. For some reason the code in my "Control" wasn't working. Turns out it wasn't included in the event list thing. Now I know.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)