Family values all messed up?!

This forum is currently in read-only mode.
  • Ok so in one of my projects, I was working with various instances of the one object. As the project progressed, I needed to add more and more private variables to the object as I needed them, for ease of reading I had to move the order of the variables around a bit.

    Later on I had to compare the object to different instances of itself, so to do so, I added the object to a family and everything worked fine.

    Even later on in the project I decided that I would like to have multiple objects instead of different instances of the same object everywhere. So I added the current object to another family and painstakingly went through all the events, replacing the objects events with the new family (there really needs to be a TGF style 'replace object A with object B' in terms of events).

    Now nothing works properly! Trying to get to the source, I made the program print out all the variables of whichever object in the newly created family that the mouse was over and low and behold, the variables were in the wrong order!!

    They were in the correct order in the events, but its like they got mixed up in the new family cause I moved them around in the original object way before the new family even existed!

    I made a demo cap here that demonstrates it so well that I originally wanted two lists, one in order and another out of order but they're BOTH out of order due to this bug(?)

    http://dl.dropbox.com/u/1289341/Help/fams.cap

    I'm not entirely sure if this is a bug or if i'm just doing something wrong with family management :S

  • I wouldn't mind some help with this as I'm about to add a bunch more variables

  • Hello.

    I'm not sure that I understand what your problem is, but I took a look at your cap.

    It appeared to work correctly for me. When I hovered over any of the objects, I got 1-10 in sequence, as I should have, for both families.

    The variables were in that order in object properties, as well, though that is purely aesthetic.

    The order of the variables for each family in the family manager were different, and jumbled, for both. I thought that was odd, but I don't see how it would matter much.

    I'm running v0.99.83, FYI. Perhaps there is a problem between versions.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well now I know something is REALLY up, here's a look at what I get when I run it

    <img src="http://dl.dropbox.com/u/1289341/Help/Fams.gif">

    Maybe I'll try deleting the persist file

  • Well I updated Construct and now it works fine? odd

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)