Collision Mask Won't Update - Bug?

This forum is currently in read-only mode.
  • I have a door-type sprite with a few frames of animation for opening, then reversed in another animation for closing. The final frame for opening and the first for closing is a blank frame. Whenever the player is touching the door while it plays its opening animation, the collision mask will stay at one of the frames before the empty one. It still shows the empty frame, but the player sprite hits it like its one of the frames from the door opening. I think its the one just before it, but I'm not sure. I believe this is a bug as I don't have anything affecting this. It just plays the animation when I click the mouse (just for testing) and closes when I hit space bar. It works fine if the player was not touching the door when it opened.

    Is anyone else having this bug?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm not sure I understand what's going on from your post. You should post a .cap so someone can take a look at what's going wrong.

  • deadeye

    Seems the system isn't using each frames collision mask, its using a mask from a random frame, and not switching when the frame does.

    You know the bug where a sprite could sometimes fall through platforms as well as solids?

    This is probably the reason why.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)