bug report: Application End and Every X ms

This forum is currently in read-only mode.
  • I just found two possible bugs. I'll be reporting them in the bug tracker as separate bugs after confirmation. I also have a simple example CAP file that I will add to the bug reports.

    Application End event is not getting triggered when the application is closed (either by clicking the window close button or by using a Application close action). The current Layout end event is also not getting triggered when the Application closes not sure if that is as intended.

    The Every X millisecond event is triggering at the start of the layout as well as every X milliseconds. Every time a layout is started or re-started the Every x millisecond event will trigger regardless of time elapsed it will then continue to trigger but only every X milliseconds. I also tested the Every X ticks event in case it had similar behavior but it does not trigger at the start or restart of an application.

    I tested all this by having dialog boxes pop up with the name of the event just triggered in an otherwise empty project. I originally ran into the problem in a small demo app I was creating.

    Thanks,

    Snoop

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've added these two bug reports to the tracker. I've included a sample cap that reproduces the problem in a simple scenario.

  • bubble

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)