Spriter C3 Addon (6-8-2019 update : additional bug fixes)

  • r153 introduced a major bug for me : No SCML object is displayed anymore... :-S

    I went back to r152 and everything is fine, so I guess something was broken in r153. Anyone has the same problem or is it just me?

  • Yes me also got this issue

  • luckyrawatlucky Rable - I checked out the issue. There were changes made and methods removed from AssetManager. As far as I can tell documentation hasn't been updated. I asked Ashley what I could use to replace the previous commands.

    More importantly, I don't think the issues with this build are exclusive to the plugin. If you check the comment section of the new release there are multiple people experiencing issues with projects not working.

  • hi Lucid !

    need your help, I upload my theme over "CONSTRUCT 3 ADDONS" page i have updated this from 1.0 to 2.0, upload is successful but its showing 1.0 as current however it should show 2.0 as current, So i want to ask you how you do your latest update as current in that page?

  • luckyrawatlucky - Aside from just creating a new version with a new version name upon upload I also edit the addon.json with the new version name. Other than that, I just upload them and they automatically appear in order.

  • i did same

    I changed version code in addon.json file and also when upload there also changed

    but mine is not changing

  • Yeah not sure what's going on. I guess I would make sure it's not marked as beta maybe? In the past when I've had issues I usually just delete the version and reupload it as a new version.

    Also, everyone, Ashley responded with a potential fix for it to work with the new c3 beta, but I probably won't be able to get to it for a couple of days.

  • Rable luckyrawatlucky

    6-12-2019

    • Fixed a compatability issue with C3 version 153

    On a side note, for anyone dealing with these v153 issues with other plugins, or with your own plugin, any 'LoadProjectFileUrl' needs to be changed to 'GetProjectFileUrl'. Ashley said he's re-added LoadProjectFileUrl to the next version to maintain legacy compatibility.

  • Thanks a lot for the quick fix! :)

  • lucid thanks for the note on AssetManager SDK, was waiting for the fix before I moved my project over which has also uses that API. Also thanks for all the work on the plugin from an active C3 / Spriter user.

  • Mikal

    lucid thanks for the note on AssetManager SDK, was waiting for the fix before I moved my project over which has also uses that API. Also thanks for all the work on the plugin from an active C3 / Spriter user.

    No problem, but after I saw your message I realized I had a typo. It needs to be changed to GetProjectUrl.(I had previously put AddProjectUrl for some reason)

    Cheers!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • lucid - yes thanks - I figured that out too (using dev console to explore the available functions.)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)