Spriter C3 Addon (2-6-2021 closure compiler compatibility and Remove Character Map action)

From the Asset Store
Jump on the mole rats and see how far you can go!
  • thanks captainsteff! Happy Holidays to you as well.

  • Now its working fine with no bug for me.

    Thanks lucid for your quick response and actions.

    Happy Holidays

  • Sorry but I got a new bug, Invisible not working on same penguin example.

    We discussed long time ago and you said you'll remove extra "opacity" and "invisible" option.

  • luckyrawatlucky

    12-17-2020b

    • Deprecated the superfluous actions for Set Opacity and Set Visible, and for the Opacity expression. The extra ACEs won't be there in projects that weren't already using them, but if they were already in your project they will remain there. Note: If you were using the extra opacity action (rather than the built in one that will remain), then opacity was being applied twice, so opacity actions will need to be adjusted accordingly to maintain the same result.
    • Fixed a bug where opacity and visibility weren't being applied for non-self-draw mode
  • its working now

    Thanks you so much for all your quick response

  • woot! we did it! Enjoy and happy holidays luckyrawatlucky

  • 1-3-2021

    • Added action to Load from URL to load projects at runtime
  • lucid Happy New Year! I found something weird in Construct 3. The pointX and pointY options are no longer available in the dropdown list when you try to use an SCML image point (please see image). The ones that were already in the code still work and you can copy an old event and change it, if you only change the name of the point in the quotation marks.

    I'm using the addon 1-3-21. Thanks for your help!

  • captainsteff Thank you. Happy New Year to you as well!

    The pointX and pointY expressions were replaced by objectX and objectY, which can be used for any object (points, boxes, sprites, and bones), as opposed to just points.

  • Oh! I missed that one. Sorry. Thanks a lot!

  • Hi,

    Is there an example on how to use "override bones with IK" ?

    I can't seem to get it working, my character disappears when I use it (and freeze the game in debug mode)

    I'm trying to adjust the feet so they follow the ground slope angle using:

    every tick -> Override bones (Parent: lowerleg , Child: Feet, as they are set in Spriter) & set X/Y to a dummy sprite following the slope angle (and pinned (X,Y) to the character) - while a "sliding" animation is playing... but my whole character just disappears instead

  • johnsmith

    Hi,

    Is there an example on how to use "override bones with IK" ?

    I can't seem to get it working, my character disappears when I use it (and freeze the game in debug mode)

    You were using it correctly. This was a bug from the update to C3 runtime that was never noticed until now.:

    1-15-2021

    • Fixed a bug where using Override Bones With IK would freeze the game
    • Fixed a bug where using bezier curves in an animation would freeze the game
  • Works perfectly now, thank you very much for the quick fix lucid

  • Hi lucid,

    I think there might be a problem with IK override and blending animation.

    Without blending, override is working fine (although from time to time it seems to "jiggle" a bit but maybe that's my setup ?), but with blending, the override bones are like they dont know what to do until the transition is over.

    I've made an example in C3 (R225 stable) if you want to take a look:

    Link

    It's also happening with "override Object" when setting X or Y the object (head in my example) moves away during the blending.

    Not sure if it's me doing it the wrong way or a problem with the plugin ?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi lucid. The file i've sent you the last time now works, but there are other issues always only in c3 runtime...other animations disappears, but only if executed in a certain order (this problem disappears if i disable loop animations in events). There is also an issue with blending animation, where some parts of the character disappear, and other strange glitches between some animations, as weird barely noticeable but annoying "out of phase" frames.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)