[Solved] How do I solve this framerate drop?

  • Hi everyone, i'm actually doing some snowboard physics game prototype, but i'm experiencing a weird framerate drop and cannot figure out where it come from.

    After a few time playing it the fps go from 60 to 15 and never go back to normal. It seem to appear when the board collide with the ramp in a certain angle and/or amount of force, but since the layout is reloaded after that why the framerate stay low.

    As you see i'm quit stuck in my search of understanding the problem, so i'm asking for your help.

    capx file: dropbox.com /s/a00no58mnxkja0l/ snowboard_proto.capx?dl=0 (remove spaces)

  • I can't reproduce the lag, mine stays at 60fps and I played through about 20 tries. If you debug the game it shows about 6% CPU utilization, maybe something is happening in your browser or on your machine causing it to lag? I would check your debug stats too and see if you can see what might be the issue.

  • I can't reproduce it either, you might want to try using bounding box instead of collision polygon for the physics settings though, couldn't hurt as far as I can see..

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'm never higher than 4% cpu usage in the debugger, anyway, i've followed your tips and looked what could go wrong on my computer.

    After a reboot and disabling my antivirus/firewall the problem was still here, i then reinstalled construct 2 and everythings work fine now.

    Thanks a lot

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)