Sudden slowdown in Chrome

  • A game I've been building has been running very smoothly in Chrome for the past 2 days.

    All of a sudden the preview has started to be quite choppy with a low frame rate.

    I ran in debug mode and it says that I'm getting over 45fps, but that's not what I'm seeing on screen.

    Is this a Chrome problem, or a 'my programming' problem? I've got very few objects in the level and a couple of webgl effects applied to layers.

  • Hard to say without a capx to look at - it is very likely to be to do with something you've recently changed rather than a bug, but anything is possible. It could be anything from an unnecessary For loop slowing things down to the use of a WebGL effect if you're using an older computer. Try turning WebGL off and see if that fixes it (this is a problem I frequently encounter on my computer). I can't think of any other possible quick fixes unless you're willing to share a capx, though. Hope this helps.

  • What's it like in Firefox or I.E. ?

    Have you kept earlier iterations of your project?

    Also, Have you added any 'Addons' to Chrome recently? Try disabling addons and test.

  • Thanks for the responses people.

    I'm not using much webGl and my computer isn't that old, so I didn't think it was that.

    As for add-ons in Chrome - no, no recent ones and none updated recently either from what I would see.

    For, for posterity, funny thing is when I put the power cable back into my laptop, it all proceeded to speed along like before again! So the problem was running off the battery rather than the direct power. Strange. I just hope it doesn't turn up in the final game - Ludum Dare 28 here and I've only got 4 hours to go!

    Thanks again for your time!

  • that answers that. Laptops reduce the GPU power use down to %75 or so. If you want to remain at 100% your going to have to modify that setting.

    Your going to have to google that. But I know the settings exist. My wifes latop would crash when the GPU ran at %95+ but fine at 95 and less. So i had to set the setting while plugged in to run at %95. No problems since then.

    So hunt the setting down and you will be fine at Ludum dare.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Many laptops ship with dual GPUs: a really weak one with poor performance to use as little battery power as possible, and a more powerful battery-draining one for gaming and high performance. (Or in some cases, one GPU with two power modes, with the same effect.) Pulling out the power cable often switches to the low-power mode and starts using the weaker GPU or low-power mode. This is a normal result with laptops and isn't a bug.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)