Spriter/C2 - (8-14-2019 - Spriter 2 Roadmap and News in latest post)

  • lucid - it seems like "set opacity" function isn't working for my sprite families.

  • PSI are you setting it every tick?

  • lucid - no, I had it set to trigger once.

  • Try setting it each tick. As Spriter plays back the animation it sets the opacity for each sprite according to the animation.

  • lucid - OK. Also, I am having my attacks spawn from the wrong area again. I'm using the scml plugin updated on the 24th and C2 release 173. Any ideas?

  • Send me the capx if you could please.

  • OK. Also I tried to set the opacity every tick and it still wouldn't do it. Thank you.

  • Sent.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • lucid - I tried to apply some effects to a family of sprites last night and it didn't work either. It seems that all of the new format files (with the entity name in them) seem to not accept effects or opacity changes, unless I'm missing something. Thanks.

  • A couple of images in the animation doesn't appear when I put the game online, but it all works fine when I test the game offline in C2. Any idea why that is? There are no weird characters in the filename; non english letters in the file/object name seem to make Spriter images invisible in C2 so watch out for that.

  • Hi After a system update/restart I double clicked on my .scml and suffered a few minutes of horror thinking that some of my animations had disappeared. However, when I opened the project .scon file they were all present and correct. Was this my misunderstanding of project file management or could this be a bug? I'm using the b8_2. Thanks.

    Edit to add that the files that were imported into C2 worked correctly as well - the file manager showed the last save date for the .scml as over a week ago even though I had overwritten it frequently. Having opened the .scon I have been able to successfully overwrite the .scml file....

    Edit 2. I was wrong - one animation I created has disappeared although it seems to be saving ok now. I'll PM you a zip of the project.

  • lucid - I recently imported the mutant zombie into my game. Though it looks perfect in the spriter program, it's arm is displaced when it attacks in C2. Any idea what the problem may be? Thanks.

  • lucid

    I create new Spriter project and then imported another Spriter project into it and it was imported without char maps. Is that a Spriter issue?

  • I will look into it I apologize to anyone waiting for me to get back to them about a capx. We're closing up the current build of Spriter, so most of my time is one that until the build comes out sometime in the next week. Thanks for your patience.

    Bass_X - you mean within Spriter Pro, the import another Spriter project into a Spriter project? or you mean a C2 project using Spriter, and it didn't import the character maps into C2?

  • lucid

    Within Spriter

Jump to:
Active Users
There are 2 visitors browsing this topic (0 users and 2 guests)