Spriter/C2 - (9-16-2019 - bug fix)

  • lucid

    And the last important noobish question, I'm very sorry for it. I forgot to add a body part to my hero (a tail to the wolf) and now I have more than 12 animation without this body part. Is it a real situation to add this body part and how to do this? When I drag the new body part on the zero in timeline it nonetheless appears as an animation.

    P.S: brashmonkey.com/forum/viewtopic.php

    And may be it will be useful, I think I found bug there

  • lucid

    Really noobish question:

    I have character's parts (images) in the same folder with the Spriter files (scml/scon). I want to add another skin (character map)... How can I move the current used images into a folder ?

    It's a good question, but unfortunately there's no way to change the folder structure after the fact, without actually editing the scml file. (If you decide to try this, just load the scml file in a text editor, and just change the filepaths to the new paths at the beginning of the file in the <folder><file> structure. We will be adding a simple or automatic way to change or detect changes in image paths in one of the upcoming versions of Spriter.

    lucid

    And the last important noobish question, I'm very sorry for it. I forgot to add a body part to my hero (a tail to the wolf) and now I have more than 12 animation without this body part. Is it a real situation to add this body part and how to do this? When I drag the new body part on the zero in timeline it nonetheless appears as an animation.

    P.S: http://www.brashmonkey.com/forum/viewto ... =9&t=15662

    And may be it will be useful, I think I found bug there

    You can paste an object to all frames of an animation by using the shortcut Control Shift V

    Also, when using Spriter with C2, it's important to always use the latest beta, in case there are changes to both the program and plugin that work in conjunction. You can do this setup automatic updates to the latest beta, or check manually for the latest beta in Spriter under the Edit menu under Settings...

    I believe your issue with the pivot points may have been corrected in Spriter B8_2. Let me know if it still occurs after updating.

  • It's a good question, but unfortunately there's no way to change the folder structure after the fact, without actually editing the scml file. (If you decide to try this, just load the scml file in a text editor, and just change the filepaths to the new paths at the beginning of the file in the <folder><file> structure. We will be adding a simple or automatic way to change or detect changes in image paths in one of the upcoming versions of Spriter.

    Thanks

  • Help: the sound I added in Spriter doesn't play in Construct 2. I have the latest version of everything installed.

  • lucid

    Any idea what am I doing wrong here ? Or is a Spriter bug ?

    The parts applied from the Character Map are not aligned correctly

  • Help: the sound I added in Spriter doesn't play in Construct 2. I have the latest version of everything installed.

    Since there are so many options for how to play sound in C2, the importer doesn't automatically add the events you need. Here's the most basic setup:

    lucid

    Any idea what am I doing wrong here ? Or is a Spriter bug ?

    The parts applied from the Character Map are not aligned correctly

    Spriter lets you set default pivot points on images that you can use in your animations. The advantage of this is say your character map had a character wearing a long pointy hat as part of the head image. Then you can set a different pivot point for the head, and your character map will align. If you look at the file palette, you can see your images in the folder and you can double click to edit the default pivot point. You can also copy and paste the default pivots from the original files using these buttons:

    For now, you have to copy each pivot individually, but there will be a shortcut in the future that let's you copy the pivots for the entire folder for files with the same names.

  • lucid

    The issue with pivot points is still exist(((( Right now the image isn't shown(((

    And who knows how to prevent sprites sticking glitch?(guys on screen are both solids) I tried to use platform hitboxes but the result seems quite unnatural, may be there is an easy way how to divide sprites when there is a crowd of enemies in one place?

    I tried to use collision boxes in Spriter, I hold shift and drag it into the project and it nonetheless appears as an animation(

  • lucid

    The issue with pivot points is still exist(((( Right now the image isn't shown(((

    And who knows how to prevent sprites sticking glitch?(guys on screen are both solids) I tried to use platform hitboxes but the result seems quite unnatural, may be there is an easy way how to divide sprites when there is a crowd of enemies in one place?

    I tried to use collision boxes in Spriter, I hold shift and drag it into the project and it nonetheless appears as an animation(

    What version of Spriter are you using? I'm not sure what you mean about sprites sticking glitch. If you're asking about how to use Spriter in a basic platform situation, the tutorial linked in my signature should be helpful.

  • lucid

    It is B8_2. I tried to unistall and install the software again and nothing has happened(

  • lucid,

    Check you pm's - I've sent you a bug report b8_2 / r174 with capx. Thanks!

  • Bass_X if possible, please send your Spriter project and if relevant your C2 project to and I can take a look for you.

    thanks will do

  • Thanks for all the hard work on Spriter and the importer plugin.

    Unfortunately I recently updated to the latest importer and am now experiencing some trouble with legacy scml/scon files. To be more specific, the files import into C2 fine but when I run the layout they're invisible. Setting an action to make the sprites in the family visible shows them, but no animation plays.

    As I mentioned I've updated to the latest import plugin, running Construct r174 and Spriter b8_2 and have the three Custom Save Options checked.

    The GreyGuy works fine, as does any new Spriter file I create and import.

    However, when I re-save any of my older files or even any of the files in the art pack (e.g. PlatformerPack\player or Goblin_enemy) I experience the invisible / no animation problem. Any ideas?

  • kirbyUFO - The way files are named changed at some point. The individual sprite names now contain the entity name as well so you'll need to save your old files with the new options and re-import them with a different name, then change all of your old events to refer to the new spriter object. You can right click on any event or selected number of events and chose "replace object," to make the transition fairly easy.

  • PSI Thanks for the response =) That makes sense, I had a vague idea that I was going to need to update all my events after importing with the new Spriter format so it's good to have confirmation on that.

    I did some more testing and it seems that my simpler legacy animations work fine when resaved as .scml and .scon with the proper custom save options, so that's a relief. Unfortunately my main character which by far has the most animation data still has the invisible sprites/animation problem.

    Also, when I try to play an animation with a "Set Animation" event it pops up the following error:

    Uncaught TypeError: Cannot read property 'length' of undefined

    http://localhost:50000/Spriter_plugin.js, line 2272 (col 32)

    Edit:

    Okay, just tried deleting all but one animation in the file and it worked, so maybe I'll just have to go through 38 animations and find out which are causing a problem.

    Edit 2:

    Found the culprit! I had saved a new version of this character's head sprite into its root folder and made the mistake of swapping it in C2 rather than overwriting it. When my animator went to work on it in Spriter, she swapped in the alt sprite that should have just replaced the old one. To fix the duplicate sprite I had edited the scml file manually to remove any reference to it, which worked fine except for this one animation. On a few frames, the object list showed a blank sprite in the Z-Order list and the head was remaining in place while the bone moved, so I swapped it for the sprite it should be and all is working properly.

    In the future I will definitely avoid adding unnecessary and confusing pngs to the root of the animation folder.

    Now to resave all the other animations and fix the event references and move the updated names into their appropriate folders for organization and make sure the new sprites are in the right families.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Glad you figured it out!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)