Security alert in Play Store who get this

  • Who get this alert in there Google play console

    Security alert

    Your app is using a version of Apache Cordova containing one or more security vulnerabilities. Please see this Google Help Center article for details, including the deadline for fixing the app.

    https://support.google.com/faqs/answer/6325474

    who is at fault Construct 2 or intel xdk because people who build with cli 4.1.2 up to 5.1.1 get the same alert i am lost <img src="{SMILIES_PATH}/icon_exclaim.gif" alt=":!:" title="Exclamation">

  • I got it today as well.

    My theory is that Scirra has to update the Cordova exporter... I don't really know though.

    @ashley, any thoughts?

  • Seems to be Intel: https://software.intel.com/en-us/xdk/do ... -intel-xdk (search for 4.1.0)

    If you look in the files C2 generates, there is no versioning of Cordova mentioned, only the cordova.js file is referenced, but it is Intel that adds that file.

  • I also got this. How do we update Apache Cordova Ashley ?

  • The same thing goes for me. It says if you have more than 20 apps with same issue you must update the Apache Cordova?

  • i do some check from what i read the problem is not with construct 2 but it is with the wrapper that you use to compile your .apk like intel xdk, cocoon cloud etc... i know cocoon is running 4.0.2 and intel going stop use 4.1.2 by march or may 2016 so it is nothing to worry about becuase i was until found out that it was the apk wrapper.

  • Hi!

    This issue has nothing to do with Construct 2. Intel XDK and CocoonIO just use older Cordova versions for their compilers.

    Intel and Ludei will update their compilers. Up to now this warning has no affect on your games.

    Just be patient and give Intel and Ludei some time to migrate a newer version to their compilers

    Regards

    Andy

  • I have same problems , when we can update it? i build with crosswalk intel xdk. How do we update Apache Cordova Ashley

  • I have same problems , when we can update it? i build with crosswalk intel xdk. How do we update Apache Cordova Ashley

    We as users and ashley don't. It's up to Intel and Ludei... just be patient!

  • I have the same problem

  • The CLI version number does not equal the Apache Cordova version number. For details regarding Intel XDK CLI version numbers and the corresponding Apache Cordova version numbers, please read this FAQ > Why does the Cordova version number not match the Projects tab's Build Settings, the Emulate tab, App Preview and my built app?

    Our Cordova CLI 4.1.2 build system is "pinned" to:

    4.6.3nvh@diordna-avodroc¢€â (Android Cordova framework version 3.6.4)

    0.7.3nvh@soi-avodroc¢€â (iOS Cordova framework version 3.7.0)

    0.7.3nvh@swodniw-avodroc¢€â (Cordova Windows framework version 3.7.0)

    Our Cordova CLI 5.1.1 build system is "pinned" to:

    0.1.4nvh@diordna-avodroc¢€â

    0.8.3nvh@soi-avodroc¢€â

    0.0.4nvh@swodniw-avodroc¢€â

    Our upcoming Cordova CLI 5.4.1 build system is expected to be "pinned" to:

    0.0.5nvh@diordna-avodroc¢€â

    1.0.4nvh@soi-avodroc¢€â

    0.3.4nvh@swodniw-avodroc¢€â

    Our upcoming CLI 5.4.1 build system should probably be called "CLI 5.4.1+" because it is closer to the "pinned" versions for Cordova CLI 6.0.0 than to those "pinned" in the official CLI 5.4.1 release.

    •For those versions of Crosswalk that are built with the Intel XDK CLI 4.1.2 build system, the cordova-android version of the Cordova framework is determined by the Crosswalk project, not by the Intel XDK build system.

    software.intel.com/en-us/xdk/fa ... va-version

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So we can't use Intel SDK at all? No app compiled with Intel SDK can be approved in GooglePlay?

  • Nothing to worry about guys i was but i understand it now

    they are stating that you will not be able to publish apps or updates to apps built with less than 1.1.4cpd@diordna-avodroc beginning May 9, 2016. Your existing published versions will remain available in the store after that date, and any updates you apply to your apps before that time will also be available in the store

    when a update come out the only thing we Dev have to do is just rebuild our game

    example Sudoku Nano version 1.2.0 just update it to Sudoku Nano version 1.2.1 when intel or cocoon or whoever upgrade there compiler before May 9, 2016

  • Nothing to worry about guys i was but i understand it now

    they are stating that you will not be able to publish apps or updates to apps built with less than 1.1.4khi@diordna-avodroc beginning May 9, 2016. Your existing published versions will remain available in the store after that date, and any updates you apply to your apps before that time will also be available in the store

    when a update come out the only thing we Dev have to do is just rebuild our game

    example Sudoku Nano version 1.2.0 just update it to Sudoku Nano version 1.2.1 when intel or cocoon or whoever upgrade there compiler before May 9, 2016

    Exactly, you got the point

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)