[r216] Editor window turns completely black, unusable?

  • Hi -

    I have an issue where when I open a layout in the editor, it opens and renders fine. As soon as I click anywhere in the layout, the entire window turns completely black. Once it turns black, nothing renders at all, nor can I interact with anything. Running the game works fine... but obviously I can't make any meaningful changes. This is on r216.

    Before I whack the project down and try to winnow it to a postable capx, has anyone seen this before?

    It's showing as 16.6mb memory usage, so I don't think that's it...?

    Thanks,

    -Will

  • Check your drivers and check to make sure you don't have a TON of objects in your project (if so, go to Preferences and uncheck the item cache).

  • Hi -

    I have an issue where when I open a layout in the editor, it opens and renders fine. As soon as I click anywhere in the layout, the entire window turns completely black. Once it turns black, nothing renders at all, nor can I interact with anything. Running the game works fine... but obviously I can't make any meaningful changes. This is on r216.

    Before I whack the project down and try to winnow it to a postable capx, has anyone seen this before?

    It's showing as 16.6mb memory usage, so I don't think that's it...?

    Thanks,

    -Will

    Is this happening with every project?

    If you opened one of the built-in examples, does it also happen?

    If yes, then most likely is GPU drivers.

    If it is only affecting one of your own projects, then we would need more info, and more than likely a .capx to test.

  • Thanks for the fix - I'm running in VMWare Fusion on my MacBook Pro. Turning off the 3D acceleration feature in VMWare fixed the issue. Interestingly, bumping it up from 1GB to 2GB dedicated of virtual GPU RAM didn't make a difference, but flipping the acceleration off completely solved it.

    I don't have a lot of objects (>20), but I did have a somewhat(?) large layout - apx 10,000x10,000 pixels. Not much in the way of event sheets either - maybe 30-40 events total. The layout has three tiled objects on different layers for parallax, but that's about it.

    I guess from a trouble-shooting perspective, it would be cool if the editor would report an error if the GPU acceleration bonks out, or maybe falls back to non-GPU if GPU fails. Of course, if I'm in feature-ask mode I'll just ask for a Mac native Construct 3.

    Thank you so much for the quick response!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • wiverson - you should report this issue to VMWare, and tell them their 3D acceleration breaks Construct 2.

    BTW it's not feasible for C2 to detect broken drivers - either nothing draws and there is no indication to the software that is the case, or sometimes the driver just crashes which takes down the whole program so there's no opportunity to give any other diagnostics.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)