Lines between tiled sprites

  • Hello everyone. I've searched the forums and I can find a few posts with similar issues concerning tiled backgrounds, but my issue is with animated sprite tiles. Keep in mind, I've only been putting it together for a few hours, so I know the art is rather terrible lol.

    When I use the "run" command or the debug layout the animated tiled seem to look right, but when I export the game there is almost a transparent 1 pixel grid between each of the tiles. Here is a .png of the two side by side, I ran them at the same time on my dual monitors.

    https:// It won't let me post hyperlinks sorry dl.dropboxusercontent.com/u/134981619/gpgame1/gp%20game%20comparison.png

    I've set fullscreen in browser to letterbox scale, the sampling to point and linear, turned on pixel rounding, and all my tiles are a power of 2, 16x16 I believe. It's odd to me that the animated tiles show this grid, but the wood tiles in the back do not, I guess because they aren't animated?

    Anyway, here is a .capx for the file. Any advice you guys could give would be greatly appreciated.

    https:// same problem here with the link, hope this works. dl.dropboxusercontent.com/u/134981619/gpgame1/GP%20Game%20test2.capx

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • just remove the words between the https:// and the dl. to get to the pic and file. Sorry about that guys.

  • If you want the smooth route (linear and no-rounding) then you need to change the coordinates or make the graphics 1 pixel wider/higher. Only way to reduce seams.

    If you want to solve without that and don't mind stuttering then just change to point and rounding.

  • You need letterbox integer scale. The ordinary letterbox scale can use a floating-point scale which can show seams. Alternatively implement an overlap like alspal suggests.

  • Thanks for the quick responses you two. I'll try that when I get off work and it will probably fix it. Worst case scenario, I'll go back and add another line of pixels to the tile.

    I'm curious though, shouldn't using a 16x16 tile along with a 16x16 or 8x8 snap-to-grid already make them seamless? They seem to work perfectly on the still frames, but not with the animated ones.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)