Container/Event touch problem

  • Hi

    I have 2 object types in a container. Event on one object instance -> Action on its container twin type instance doesn't work with 'Touch - Is touching'. It does however work with 'Touch - On touched' and 'Mouse - Cursor is over'.

    I would expect only one container instance, to be affected by the given event and corresponding action, in all 3 cases.

    What I would like to know is, do I misunderstand something about events/containers/touch or is this a bug?

    (Capx in post below - forum will not allow me to edit and update post, when it contains a hyperlink.)

    Cheers,

    thegrind

    (edit: improved explanation)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Very simple linked capx exemplifies clearly:

    http:// ak47.dk/test/demo/event_touch_demo.capx

    (Please look at the event sheet and try to toggle)

    I tested it in Chrome on a PC with a mouse.

  • <font face="Arial, Helvetica, sans-serif">@thegrind,

    Awesome find. However, I see that the bug is slightly different to how you describe it. I think something is not working as it should here, though.

    Here is what I see:

    "On touched" works correctly for me; the event causes only the Sprite in the touched Sprite2 container to rotate.

    "Is touching" and "cursor is over" affects all of the Sprites, as if the trigger was affecting all of the containers at the same time. My understanding is thtat the other Sprites should not rotate - the trigger event should only pick the instance and associated container that is touched/mouse-over. Unless anyone sees my interpretation as incorrect, I suggest you submit this as a bug report with this.

    Interesting that you don't see any effect with On Touched....</font>

  • 'On touched' and 'Cursor is over' are working fine here. 'Is touching' is affecting all sprites. Seems to be different to what both of you are saying...

  • It looks like a bug. I found the mistake and hopefully it's corrected in the next build.

  • Yes, that was also my observation. I see I managed to explain it differently in OP :)

    (OP fixed)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)