Construct can't handle many animations at once?

  • Hi, I just recently updated construct from r139 to r141, and all of a sudden the game I'm working on is consistently freezing up for 1-3 seconds at a time whenever a lot of animations are triggered at once.

    This has never happened before, even when I haven't touched the code regarding the animations in a long time. Does anyone experience the same problems after the update? This has completely broken my game, since dynamic animations are triggered in the environment almost constantly. Everything else about my game has stayed the same, only the most vital part (several animations being triggered at once) has been broken.

    I'm just asking if anyone knows if the internal animation systems has been changed around in the latest update?

    Screenshot of event in question: puu.sh/42Kd9.png

    I've done tests for myself and it's this event I've tracked the issue down too. This problem only happened once I updated to r141.

    Thanks

  • There was a change in 141 with animations and time scale. Must be related to that.

    Bug Fix

    Sprite: animations would sometimes advance a frame sooner than they ought to when changing the timescale

  • I just tested it out, and the problem still persists even after deleting the time scale actions. The issue is also present on layouts where the waveocean objects doesn't exist.

    In fact I also tried to disable all the animations, while keeping the timescale events on. This made the game run smooth again. It's linked to the triggering of normal animations!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You're setting the animation to "Pulse" on like 12 objects at once, 60 times a second.

    That's probably why it's lagging.

    Try putting "Trigger only once" below the Condition.

  • I did, nothing changed. The value only stays at 1 for 0.05 seconds anyways.

    Edit: Also as previously stated, this code has worked flawlessly for the last 3 months! of active development. This is the result of a recent change to construct.

  • without a capx it's hard to look into

    maybe help us to help you by giving a capx

  • Not that I mind or anything, but it's pretty huge. The backup capx is closing in on 1gb soon.

    The reason why I also don't think it's my code that's the issue, is that this has never been a problem up until today, and I've been working on the game 4-10 hours almost daily for months. The only change I've made from yesterday's build when it worked without issues to today was editing some sound effects for a couple of layouts. I don't see the connection between those changes and the laggy result.

    I know this isn't helping, but I am convinced this is an issue with the r141 update.

  • ok well sorry I wasn't more assistance

    best of luck

  • 1 GB?! damn!

  • Or well actually it was closer to 500mb when saved out. My bad. Still not something I can just casually share.

    @DrGreenThumbCAN: Thanks!

  • 500mb!!? damn still!

    try to disable some animations via toggle disable the group of events

    if the problem dont go away try to see if some of the objects are being spawned like 1000 times or if you have A LOT of constant loops at the same time

    can be stupid, but try to reduce the browser screen size with ctrl - and +

    it can be the sound, browser or the video card too

  • As previously stated in one of the other posts, I mentioned that disabling the animations made the game run fine again. The issue though is that the game has always run devilishly smooth while them being on up until r141.

    I've double checked my events, and there's nothing interfering with spawning of these objects (in fact they're always static and hand placed in the environment).

    I also experimented with screen size, everything from 33 % size to 200 % in chrome didn't change anything, but 25 % and lower made the game run slower. However this isn't part of the real issue.

    The game still runs 100 % smooth, except for when the player meele strikes (which is the core mechanic that triggers this animations). This has always worked flawlessly, except for the r141 update...

    I also update my video card drivers. No change.

    The reason why I doubt it is the sound at work, is that this slowdown is present also in layouts where I haven't touched ANYTHING since the last update.

    If anyone wants to test out the last stable build the link can be found here: dl.dropboxusercontent.com/u/5323353/Klang12_8.zip

  • We can't help unless you make a report to the bugs forum following all the guidelines. We need a minimal .capx reproducing the problem, a comprehensive description of the steps to reproduce it, a report on which browsers the problem occurs in, etc.

  • Hi Tinimations,

    I downloaded your build. Cool idea and a very cool music :-)

    The game still runs 100 % smooth

    Well, I'm on a 3-year old quad core, with a GTX, and it does *not* run smoothly at all. It seems to me that it does not exceed 3-10FPS on the intro screens.

    I am very interested in the node-webkit performance, because I'm working now on an edu-game which must run smoothly on an ATOM-powered Win8 tablet (and so far it does ok, even if graphically it's ultra simplistic).

    If you can figure out some nice node-webkit optimalisations, please be so kind to share some tips.

    Good luck with the game!

    Greg

  • Ashley Just posted a stripped down capx that reproduce the problem in the bugs section.

    @CJK Oh... Did it keep running that poorly after the title screens? Heard some computers completely freaks out of the game, but it's never happened to the PCs I've personally tested it on.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)