Spritefont is misaligning when on full screen

  • Link to .capx file (required!):

    dl.dropboxusercontent.com/u/47035927/temp/bug_spitefont.capx

    Steps to reproduce:

    1. create any sprite-font;

    2. use the preview;

    3. watch the misalign;

    Observed result:

    The sprite is misalign where it should be as the original.

    Also, if you export to CocoonJS, it will cut a half pixel of the superior border too, showing traces over your words.

    Before anyone ask if my graphic card is update, yes, it is with the latest stable driver for windows 8. Also, my Galaxy S3 and S4 are all fully updated with the latest Android version too.

    Expected result:

    Should be perfect horizontal.

    Browsers affected:

    Chrome: yes

    [tube]http://www.youtube.com/watch?v=bIUS4rPb76A[/tube]

    Operating system & service pack:

    Windows 8 Fully updated.

    Construct 2 version:

        R137

    EDITED: PLEASE WATCH THE VIDEO ON FULL SCREEN AND HIGH RESOLUTION, OTHERWISE YOU'LL NOT BE ABLE TO SEE THE PROBLEM.

  • Closing as not a bug: it's just because you use 'scale outer' fullscreen mode.

  • Ashley, please, reconsider the issue.

    It's very frustrating to talk in english, because I can't express or use all my knowledge to make a phrase covering the issue as I like.

    Well, trying again. The issue is affecting my game in many ways, but it's hard to see on the first time and need attention to the details.

    Here is a screenshot showing the issue and upper and on the bottom is how it's right without the full screen, even using the scale outer.

    <img src="https://dl.dropboxusercontent.com/u/47035927/temp/spritefont%20bug.png" border="0">

    Also, as I said, this game will be published on Androids, and I'm near to the publishing date, but, unfortunately, when exporting to the CocoonJS, the issue of misalignment return, even using letterbox scale, scale, scale outer or any other method, but there, on Android, the font create a line on the top of each letter, with approximately a half pixel, like the image above, but on the top of the letter.

    If necessary I can search for a program to take a screenshot of the issue for you, but I can't stay with this issue, because it's affecting negatively the quality of all the job with an unprofessional polishment, where I'm incapable of solve.

    So, if it's looking right and is on purpose, it's worse than I was expecting...

    Thank you.

    Edited:

    Why wait, here is the APK, you just need to use it with the CocoonJS Laucher App

    https://dl.dropboxusercontent.com/u/47035927/03-ZOMBIE/apk/wheniwasonazombieapocalypse.zip

    http://wiki.ludei.com/cocoonjs:launcherapp

  • I can't reproduce any issue on Chrome, Firefox or IE, they all look correct for me on Windows 8. It also looks like the type of glitch that is caused by a graphics card driver bug, which is still possible even if you have the latest drivers.

  • Ashley, did you tested on android with the CocoonJS laucher? It's showing the same issue there.

    I'll start to redraw the entire sprite font image to offset 1 pixel from the border between each letter to try solve the issue.

    As I said, it's affecting very negative the game and 90% of my feedbacks from the beta testers are about this issue.

  • I can't reproduce it in CocoonJS either, using a Samsung Galaxy S3. However I'm using a slightly newer version of the launcher that Ludei have sent me, so it may be something they've already fixed.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley,

    I have tested the game on 9 computers now, on my office, using 1 laptop and 8 desktops, so, here are some numbers to show:

    Computers with Windows 7 (7x):

    Graphic Card: Nvidia (1x);

    Issue: Not affecting;

    Graphic Card: ATI Radeon (6x);

    Issue: Affecting;

    Computers with Windows 8 (2x):

    Graphic Card: ATI Radeon HD 6670 and ATI Radeon HD 7670M;

    Issue: Affecting;

    Maybe it's an issue with the Radeon Drivers? Because on the 6 computers we have persons who update and who don't, and drivers from various ages, but everybody is being affected by the issue.

  • Sounds like a Radeon driver bug then. Did you test different browsers? IE uses a different rendering engine internally to either Firefox or Chrome, so it may not reproduce even where you've listed a computer as "affected". Have you also tried updating every single machine's drivers to the latest version?

  • Ashley, using Firefox give the same issue of Chrome, but on IExplore it appear blurred and show the issue on the upper border without the full screen actived.

    <img src="https://dl.dropboxusercontent.com/u/47035927/temp/sprite_font_issue.png" border="0">

    After updating 5 of the computers the issue still happening.

    I did a post on the ATI Forum asking for help: http://goo.gl/fvT6I

    Do you have any tip I can follow to solve it better than remaking the spritefont image again?

  • TELLES0808 - try leaving at least 1px of transparent space between each character in the sprite font image. The lines in the IE screenshot is the character above in the sprite font image bleeding through.

  • After moving one pixel from the edges it still rotation like 0.001 degree, but the corner problem is solved.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)