[Solved] NWJS Not Completely Closing In Preview Mode

  • Problem Description

    NW.js is still leaving a process behind when using it in C2 Preview mode.

    Manually shutting down the process is required.

    Attach a Capx

    Click HERE!

    Steps to Reproduce Bug

    • Open the project
    • Preview using NW.js several times (Change between debug and normal preview from time to time.)
    • Always close the project using the windows "X" symbol

    Observed Result

    Eventually NW.js will leave a process behind, if unnoticed these processes will eat up a lot of memory.

    Expected Result

    NW.js should close either way and not just when exported.

    Also note that the browser close action is working fine as a temporally workaround event. (eg. On ESC pressed > Close Browser).

    Affected Browsers

    • NW.js: (YES)

    Operating System and Service Pack

    Windows 7 with latest updates and up to date drivers.

    Construct 2 Version ID

    Newest release r227 Steam release. [Personal Edition]

    Additional maybe useful information:

    • NW.js version: v0.14.0
    • Checked C2 data with the Steam software data check system (0 Errors Found)
  • Can't reproduce: previewed 10 times alternating preview and debug and it worked fine.

    Besides it would be a NW.js issue if it left behind a process, the C2 engine doesn't control that and I doubt there is anything we can change in our code to influence that. It's probably better to head straight to the NWjs bug tracker for this kind of issue.

  • Can't reproduce: previewed 10 times alternating preview and debug and it worked fine.

    Besides it would be a NW.js issue if it left behind a process, the C2 engine doesn't control that and I doubt there is anything we can change in our code to influence that. It's probably better to head straight to the NWjs bug tracker for this kind of issue.

    That is weird, so I am the only one with this issue?

    I guess I'll wait for the next release and see if they fixed it else I'll have to report it there, thanks for you response.

    It might be worth mentioning that I switched from desktop (NW.js) to mobile (FF) preview from time to time too.

  • This is no longer occurring using v0.14.5 of NWjs.

    I don't understand how it fixed itself but perhaps the NWjs devs. secretly updated that part?

    Anyway, this can be closed for now.

  • Hi! I have the same problem. Nwjs is not closing and slowing my computer after launching several times if not to close it every time through CTR/ALT/DEL.

    Configuration of PC: Windows 10, Pentium E5200, 4000 RAM. I am using latest version of nwjs.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi! I have the same problem. Nwjs is not closing and slowing my computer after launching several times if not to close it every time through CTR/ALT/DEL.

    Configuration of PC: Windows 10, Pentium E5200, 4000 RAM. I am using latest version of nwjs.

    @Vladimir

    This is a closed and solved bug report and as the 'sticky' says, you should not post in this section.

    If you think you have found a bug, please make a new bug report ensuring you follow all of the Bug Reporting Requirements.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)