[SOLVED] Multiplayer plugin not sending/receiving messages

  • Problem Description

    The multiplayer feature isn't receiving messages from other connected players.

    Attach a Capx

    I used the official Multiplayer Chat tutorial.

    Description of Capx

    Creates a chat room that hosts and peers can join and send messages to each other.

    Steps to Reproduce Bug

    • Open and run the multiplayer chat tutorial
    • In a separate instance of Construct 2, open and run another copy of the multiplayer chat tutorial *OR* duplicate the tab
    • Login to both chat rooms using different names.
    • Send a message from the host window.
    • Send a message from the peer window.

    Observed Result

    The messages appear in the chat for whoever sends it, but nobody else.

    Expected Result

    The message would be received by all peers.

    Affected Browsers

    • Chrome: YES
    • FireFox: TBD
    • Internet Explorer: N/A - multiplayer not supported
    • NW.JS: YES

    Operating System and Service Pack

    Windows 7 Professional Service Pack 1 Build 7601

    Construct 2 Version ID

    Release 255 (64-bit)

  • It worked for me.

    I can see messages written in both windows.

    Host messages are seen in both windows.

    Peer messages are seen in both windows.

  • Strange! Thank you very much for testing it out. Are you on Windows 7 with Construct version 255?

    I'll keep trying when I get back from work, but after two hours of trying this morning I had no success. Maybe there was just a random problem with the signalling server at the time...

  • I just tested using Win 7 pro x64 and r255 and peer received post from host fine.

    I used Firefox as host and NWjs as peer.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Use Win10 64.

    C2 R254 64bits.

    You're welcome.

  • Firefox worked! A clean install of Chrome worked as well. I'll try NW.js later on.

    I couldn't figure out why, so this won't be much help to anyone in the future

    But thanks to you both for quick help!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)