[r218 UPDATED!] NW.js (α7) Plugin Is Not Working Correctly

  • Problem Description

    The plugin is almost back to its normal state, most of the errors are fixed.

    Short Reminder: This report was made to keep track of the features that are currently not working with the latest version of NW.js .

    OLD/v2: Some actions and expressions of the NW.js plugin still return a javascript error.
    (Tested: Set width/height, Request Attention, Set Window Title and many more available in the Capx below.)[/code:3ngpgm11]   
    [code:3ngpgm11]OLD/v1: The NW.js Plugin ACEs are not working at all, the exporting to NW.js seems to work but 
    the games (Win32&64 tested) just show a blank black screen and do nothing else.[/code:3ngpgm11]   
    [b][u]Attach a Capx[/u][/b]
    [b]Example Capx File:[/b] [url=https://dl.dropbox.com/s/r0kv0e0cms9ywyx/NWjs%20Bugs.capx?dl=0]Download HERE![/url]
    
    [b][u]Description of Capx[/u][/b]
    Includes some basic actions & expressions using the NW.js Plugin and default Buttons.
    
    [b][u]Steps to Reproduce Bug[/u][/b]
    [ul]
        [li] Download the Capx
        [/li][li] Open the Capx with latest C2 & NW.js installed
        [/li][li] Test using preview or export (I prepared some stuff to test several basic functions.)[/li][/ul]
        
    [b][u]Observed Result[/u][/b]
    The Plugin is obviously broken at some parts and returns error messages.
     
    [b][u]Expected Result[/u][/b]
    I expect it to work like it did before r217. 
        
    [b][u]Affected Browsers[/u][/b]
    [ul]
        [li] NW.js "Native Like" Desktop: (YES)
        [/li][li] Chrome: (NO)
        [/li][li] FireFox: (NO)
        [/li][li] Internet Explorer: (NO)[/li][/ul]
        
    [b][u]Operating System and Service Pack[/u][/b]
    Windows 7 with latest updates and up to date drivers. 
        
    [b][u]Construct 2 Version ID[/u][/b]
    Newest beta release r218 Steam release. (With the latest alpha version of NW.js installed!) [Personal Edition]
    
    [b][u]Additional maybe usefull information:[/u][/b]
    [ul]
        [li] 100% deleted and reinstalled NW.JS (v0.13.0 alpha 7)
        [/li][li] Checked C2 data with the Steam software data check system ([i]0 Errors Found[/i])[/li][/ul]
  • TheRealDannyyy: I was wondering why I got a black screen with the new NW.js.

    I thought I was missing something. Then I saw your post. I can confirm this.

  • TheRealDannyyy: I was wondering why I got a black screen with the new NW.js.

    I thought I was missing something. Then I saw your post. I can confirm this.

    I can confirm that on my end the exporting is fine now on Win 32 & 64 bit but the NW.js plugin is currently just a mess and seems to work only if it wants to.

  • Can confirm same bug.

    Windows 10, newest C2 Beta 218, as well as newest NWJS. 64 bit.

    Export project -> Black screen, no run.

  • I also get the following error when previewing with NW JS:

    Javascript Error!

    Uncaught ReferenceException:

    in .. /html/ajax_plugin.js : process is not defined.

    Line 55.

    ... help?

    --- UPDATE ---

    As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.

  • I also get the following error when previewing with NW JS:

    Javascript Error!

    Uncaught ReferenceException:

    in .. /html/ajax_plugin.js : process is not defined.

    Line 55.

    ... help?

    --- UPDATE ---

    As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.

    @Ricethin you might want to test out the latest version of NW.js (alpha7), maybe it is fixed now.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I also get the following error when previewing with NW JS:

    Javascript Error!

    Uncaught ReferenceException:

    in .. /html/ajax_plugin.js : process is not defined.

    Line 55.

    ... help?

    --- UPDATE ---

    As a temporary fix, I reverted to 0.12.0 NW.JS from February. Works fine.

    I have the same issue, it's been posted in the bugs forum by multple users. Thanks for the tip abpout reverting, wiill have to try that as a temp solution so I can keep working on things.

  • Most of these should be working in alpha 7, except 'request attention' which brings up an error. I've fixed that for the next beta. After the next beta/alpha 8+, please file separate bugs for each feature that is not working correctly.

  • Thanks!

    I'm still using a slightly older version of NW JS that seems to have been working.

    I have a huge project I'm working on, so I'm anxious to do any updating just yet, ha!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)