[r202]Families not picking objects

  • Problem Description

    Families not picking objects.

    [quote:3pbm115b]family1.variable=family2.variable

    Should pick all objects that have the same variable than other object. It does nothing.

    [quote:3pbm115b]Pick all family1 + Pick all family 2 + family1.variable=family2.variable

    This only works once not for all members in the family, only one family member will be pick.

    [quote:3pbm115b]For each family1 + for each family 2 + family1.variable=family2.variable

    This works fine for some reason

    Attach a Capx

    heroesestudios.com/familyerror.capx

    (i cant upload capx (there is no upload button) and can't post url...)

    Description of Capx

    Start the capx and see the result.

    This should put all squares from one family, over the square in other family with the same variable number.

    Steps to Reproduce Bug

    • Step 1 Start as is and see that nothing happends
    • Step 2 Go to EventSheet and disable the first event, then enable the second event. See the result. Only one is pick.
    • Step 3 Repeat setp2 but enable the 3º, nothing will hapend
    • Step 4 Enable the 4th, it works

    Observed Result

    No object is pick

    Expected Result

    From the first event should pick the object that have the same variable than other, and put it one over the other

    Affected Browsers

    • Chrome: (YES)
    • FireFox: (YES)

    Operating System and Service Pack

    W7Sp1

    Construct 2 Version ID

    R202 64bits

  • You need two <For each> loop to accurately express your logic.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • family event should work as normal events, since i'm not picking one element, the family is a shortcut to aply an event to all the elements in the family, is logic that it picks all elements, or at least tries to do the condition in every element of the family.

  • Closing, it's just your events are wrong. Either use event 4, or event 2 with 'For each family2' instead of family1.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)