[r142] Node-Webkit screen buffer not rezise well

  • Steps to reproduce:

    1. lunch a project in debug

    2. detach the profile window

    Observed result:

    the "gameview buffer" is just strech at the screen resolution (but the buffer isn't at the original size).

    Expected result:

    the bug is introduced by the r142 (not presente in r141), maybe the change of node-webkit v0.7 is the fault.

    Just need to initialise the "game buffer" at the screen size and rezise it if the debugger is present (and not initialise it with the resolution of the rendering "part of the windows" size)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I don't understand very well your problem with R142, the way the project view is rescale in the window is depending on your project's parameter "Fullscreen in browser" if this can help ... In C2 a node webkit window is always resizable and the debugger use is own way to resize windows as a user can do so i don't see where there is a "bug".

    You should link a capx and give full details about your pc os as explained in the bugs report section ... Bug report without these elements are closed quickly without answers of the Scirra team !

    Try also debugger mode using chrome and all common browsers (if you can) and see if the result is different.

  • I make some other test it's just a little bug when you "pause" the game in debug and detach the debugger.

    When is pause the screen buffer is streched.

    Just a little bug because when you hit 'play' again the screen refresh and you resolution is just fine

  • Can't reproduce with Space Blaster. Closing, please follow the bug report guidelines and include a working .capx example to demonstrate the problem.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)