Import Sound "Converted to AAC but failed to convert to OGG"

  • Problem Description

    Construct 2 new release (r227) causes ogg converting failure. After Importing a sound, the aac Version is converted perfectly but the ogg converting fails. This problem didn't occur on the older stable version (r221). Please see the screenshot under "Observed Result" (it shows the problem best). EDIT: Important! I even tried importing .wav sounds that already have been imported successfully! And I made sure they are 16-bit PCM WAVs at a standard sample rate, e.g. 44.1KHz <img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";)" title="Wink">

    Attach a Capx

    http://www.hinz-art.com/game/ogg_converting_fail.capx

    Description of Capx

    Its a plane project only with the audio object. Then I tried importing my wav sound. The aac version is converted, the ogg version failed.

    Steps to Reproduce Bug

      Import Sound Choose Wav File Converting to Ogg fails

    Observed Result

    Aac version can be found in the projects sounds folder. But the Ogg Version fails.

    Screenshot of the Error message: http://www.hinz-art.com/game/screenshot_ogg_fail.png

    Expected Result

    The converting process should produce both: aac AND ogg sound file and ad it to my project

    Affected Browsers

      No Browsers are affected, the problem occurs within Construct 2

    Operating System and Service Pack

    Windows 7 Ultimate (32Bit)

    Service Pack 1 can't be installed

    (But the problem didn't occur in Construct 2- r221 Version with no Service Pack installed)

    Construct 2 Version ID

    Construct 2 Release r227 April 12, 2016 (32 Bit Version)

  • The .capx isn't helpful, we need the original .wav file that you are importing. Can you provide that?

  • Hi,

    the original wav file can be found under http://www.hinz-art.com/game/6_Beamin.wav

    thanks for your support! Im desperate and looking forward to helping to find a solution and to provide it to fellows with the same problem <img src="{SMILIES_PATH}/icon_e_wink.gif" alt=";)" title="Wink">

  • I've tested importing your .wav into r227 and I had no problem - successfully imported and converted to m4a and OGG.

  • Thank you so much for testing!

    Do you have a clue what i could do now?

    The only idea i have is downgrading again and reworking to the point im at right now but this can't be the best solution i guess

  • Thank you so much for testing!

    Do you have a clue what i could do now?

    The only idea i have is downgrading again and reworking to the point im at right now but this can't be the best solution i guess

    Not at all sure why you are experiencing difficulty converting the .wav.

    I can think of 2 quick options:

    1) Download something like Audacity (which is free) and convert the .wav yourself.

    2) Wait until tomorrow and I'll upload the converted file for you.

    Option 1 would be better for you in the long term as you will have control, but until your peoblem can be remedied, the choice is up to you.

  • aaah thats so nice of you

    i thought about this option. i already have audacity and will choose 1). thanks for offer 2) though!

    anything i need to consider apart from calling the ogg file the same as the aac file?

    and one more question: how do i import the ogg file? can i just use the right click import way. and it will skip the converting part by itself? or can i sneek it in my projects sound folder some other way?

    thanks again!

    chris

  • I just tested with the converted .ogg and .mt4 files, and right clicking on the 'Sounds' folder and selecting 'Import Sounds' worked fine.

    Re: your converting problem - do any errors appear in either your anti-virus logs or the PC Event Viewer's Windows logs? There may be an issue on your PC that is preventing the convertion process.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I was also a similar situation with Construct 2 R227. Audio files are imported to the r221, are not imported with the r227. I have tried in many ways and failed.

  • scirra support supported me with one or two additional ways i could try. i didnt manage to try them yet though but ill post their answer here and my experience with it

  • I have the same problem.

    Even wav-files from C2 bundle cause the same error.

  • So strange!

    This is another tip from the support:

    Dear Chris,

    It is a good idea to put as much details as possible in the bug report indeed.

    Good luck with fixing your issue, I do hope a simple reinstall should fix it (that would be the best and nicest case).

    If it doesn't, I'm afraid you will have to find what software/driver/anything you have installed on the computer since that would have messed with the audio (new audio interface, a DAW, a sound editor with specific codecs, etc...)

    Kind regards,

  • I hope this bug will be fixed in next release.

  • I think it wont- cause scirra told me that they couldn't reproduce the error and believe the problem is on my end. Maybe somebody figures out what causes it.

  • I've no idea why this is happening, but we recently updated the audio encoders. I've restored the same encoder version used by r221, so I guess that will solve this for the next build...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)