How do I fix video frame rate?

  • So I have a video that is set to play. It is the correct format, but when it plays back, the frame rate is super slow. Maybe 2 fps. Is there a way to get videos to run smoothly?

    The video is on it's own layout and is set to autoplay. The webm has the sound embedded within, and fits into the whole frame. I did try shrinking it to see if it was a rendering issue, but it didn't speed anything up. I don't even know if there is a way to get it to run smooth, but there's gotta be a way to make smooth cutscenes! Is there a plugin that makes things work better? Or maybe a way to play videos without using the video tool?

    If you have any suggestions or advice, I'd love to hear it and I'd appreciate it!!

    Thank you!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I found that it may be linked to the project option...Enable WebGL. With this set to Yes (which seems to be the default) I had the same problem you did. If I set it to no, or activated the Enable WebGL option inside of Chrome, it corrected the issue.

    If Chrome doesn't have this on by default, I'm not sure I like the idea of using it in the game as I then have to rely on the user to know how to set ab maintain browser settings.

    You can find the Chrome settings if you enter this in the address bar...chrome://flags

    Hope that helps.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)